0
$\begingroup$

enter image description here

Hi all, I'm super new to Blendr (as in, day one) and I'm trying to edit a pre-existing mesh. I've managed to get through quite a bit of the learning curve but I can not seem to get rid of the two black triangles pictured here. I've tried going through so much of the forum for similar issues but so much terminology is brand new as well --

Long story short, can anyone give me a tip on what I'm looking at and how to fix it? Thanks in advance.

$\endgroup$
  • 1
    $\begingroup$ you sure that isn't just the texture? If you select all the vertices with a and then do spacebar > tris to quad. If the black stays it's definitely your texture. $\endgroup$ – Sidar May 10 '18 at 16:36
  • 1
    $\begingroup$ @Sidar I'm an idiot, it's my texture. Thanks! $\endgroup$ – Midi May 10 '18 at 16:49
  • 1
    $\begingroup$ Not an idiot, but a beginner. $\endgroup$ – Sidar May 10 '18 at 16:53
2
$\begingroup$

Often times faces appear darker if their normals are flipped. In computer games these faces are usually not rendered. Blender however makes sure that they are and hints to the user that the normals are flipped. To test if it's a normal issue you should check enable backface culling in the 3D views properties panel

enter image description here

Your faces however seem pitch black thus this could imply a few things:

  • Faces are assigned to a material which is pitch black

  • Faces are mapped to a black/empty region in your texture

  • You're seeing the vertex colors assigned to the vertices.

edit:

enter image description here

$\endgroup$
  • $\begingroup$ Thank you again. I can't find anything in my texture that lines up with this at all, even after experimenting with multiple parts of it. I deleted the swath of the mesh just before this that can be seen below the triangles, however those stubbornly refuse to part ways. $\endgroup$ – Midi May 10 '18 at 17:06
  • $\begingroup$ if possible can you upload the file ( if it's all legal) $\endgroup$ – Sidar May 10 '18 at 17:48
  • $\begingroup$ Yes! Let me uh -- figure out how to -- dropbox.com/s/67k1oiwssrn53lj/giorno.blend?dl=0 Hope that's okay! Sorry for all the trouble. $\endgroup$ – Midi May 10 '18 at 18:06
  • $\begingroup$ dropbox.com/s/b9br7xn5k07dkh2/giorno.png?dl=0 Here is the texture as well, just in case. $\endgroup$ – Midi May 10 '18 at 18:10
  • $\begingroup$ @Midi Those faces are mapped to black/empty space, check my edit $\endgroup$ – Sidar May 10 '18 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.