0
$\begingroup$

I have a problem when using the smooth modifier on my terrain mesh. When used it cause a gap/hole in the terrain. See the images below before and after using the modifier.

enter image description here enter image description here

I should also mention that I have previously split the mesh and then joined the mesh back together right where this gap occurs.

As far as I can see, all normals are pointing upwards and duplicate vertices have been removed.

I hope this is easy to fix!

Thanks!

$\endgroup$
  • $\begingroup$ "I have previously split the mesh and then joined the mesh back together " so the modifier smooths vertices of one mesh - into one side, and another one - to another as likely you didn't remove double vertices after joining. $\endgroup$ – Mr Zak May 9 '18 at 22:18
  • $\begingroup$ @MrZak Duplicate vertices have been removed already, but still the gap occurs. $\endgroup$ – Marcus May 9 '18 at 22:22
  • $\begingroup$ The gap means there are duplicates otherwise modifier wouldn't move vertices away from each other. How did you remove the duplicates? If you want investigation of your exact mesh then share the file blend-exchange.giantcowfilms.com $\endgroup$ – Mr Zak May 9 '18 at 22:35
  • $\begingroup$ @MrZak I just realized that the vertices were not removed. What I did before was to split the mesh and then rejoined it (did not move the meshes around or anything). But still the remove doubles function doesn't seem to work in my case? See my first post, added a animation showing the double vertices. $\endgroup$ – Marcus May 9 '18 at 23:00
  • 1
    $\begingroup$ If you have unconnected geometry due to duplicate vertices, you will run into those kinds of errors when using subsurf. Remove doubles or weld disconnected vertces together. $\endgroup$ – cegaton May 10 '18 at 0:48
1
$\begingroup$

Solution:

  1. Select mesh
  2. Go into Edit Mode
  3. Ctrl + TAB and select Vertex mode
  4. Select all vertices by pressing A
  5. Press W and select Remove doubles
  6. In the options panel, set a number greater than 0

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.