15
$\begingroup$

On my PC when I open Blender I always need to manually press maximize button on the window. Is this just something on my PC or is this how Blender starts?

Is there anything I can do so that it's always open maximized?

$\endgroup$
32
$\begingroup$

It's controlled based on the window when you save your startup .blend.

To make it default to maximized:

  1. Maximize the window.

  2. CtrlU> Save Startup file, or File Menu -> Save startup file.

Note that if you make any other changes (not including the splash screen), they will be saved as defaults as well.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Saving the startup file is not working in windows 8.1. Neither the screen nor the position is saved. I use blender version 2.75. $\endgroup$ – Christoph Werner Jul 15 '15 at 19:03
  • $\begingroup$ Using Windows 10 and Blender 7.7, this does work for me. $\endgroup$ – marts May 21 '16 at 18:01
  • $\begingroup$ @marts - you're way ahead of the curve man $\endgroup$ – Neil Jun 7 '16 at 10:54
  • $\begingroup$ I assume he was trying to reply to @christophwerner. Marts, just in case you didn't know, users besides the post authors won't be notified unless you mention them with an @<username> $\endgroup$ – gandalf3 Jun 7 '16 at 15:38
  • 1
    $\begingroup$ worked in Windows 7 & Blender 2.78a. Failed the first round of save/close/restart, but I modified the view (or something else), saved as default, closed, re-opened Blender and voila. May be it saves nothing when changing only the window size. Thanks @gandalf3 $\endgroup$ – Ivan Ferrer Villa Dec 5 '16 at 23:58
3
$\begingroup$

In windows look for the icon you use to start blender. Right click to bring out the contextual menu, select Properties an in the target path add -W at the end.

enter image description here

Blender will open maximized with no borders.

(for windows 8 go to the start menu, right click on the blender icon and select Open File Location That will bring you to the folder where windows stores the shortcut used to open blender. Right click on it to access the properties and edit)

For other options read: https://www.blender.org/manual/advanced/command_line.html?highlight=command%20line#window-options

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Not sure about Windows but for Linux users the -W parameter makes Blender run in Fulscreen mode, which is different than the maximized window, because Blender then covers the whole screen, hiding any system panels and omitting window decoration. Not sure it that's what you wanted. $\endgroup$ – unfa Aug 2 '16 at 10:41
2
$\begingroup$

I know this is an old thread but I found a solution (for Windows 10 at least). Under the properties for the Blender shortcut, you can go to the "Run" dropdown and pick Maximized. enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ This just maximizes the console window for me. The main Blender window remains unchanged. $\endgroup$ – jdk1.0 Jan 3 '19 at 21:54
0
$\begingroup$

Blender 2.80 (it's still in Beta but you can get it here: https://builder.blender.org/download/):

| improve this answer | |
$\endgroup$
0
$\begingroup$

I know this thread is quite old, but, since it is - at least for me - the first result for the search "blender star maximized", let me share my solution (windows 10):

First, I did what @gandalf3 said, and saved the start-up file with the window maximized. Still didn't work.

Then, instead of using the desktop shortcut that is automatically created after installation, I actually went to Blender's folder (C:\Program Files\Blender Foundation\Blender) and opened Blender.exe directly and voila, it worked.

So I deleted the desktop shortcut and re-created it by right-click dragging "Blender.exe" to the desktop and "Create shortcuts here".

It is very strange, since the new shortcut has the same target as the previous one, but hey, it worked so I'm not complaining.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.