4
$\begingroup$

I tried to comb hair particles in particle edit mode, but the hair didn't show up after rendering.

This is before I combed the hair and the render result I got.

before I combed the hair

And this was what I got after I combed in particle edit.

after I combed in particle edit

And here's my .blend file

Any help will be very appreciated.

$\endgroup$
  • $\begingroup$ Could you upload a .blend or some screenshots? Without more info it's hard to say what's happening.. $\endgroup$ – gandalf3 May 30 '14 at 9:10
  • $\begingroup$ Sure, I have added the screenshots and the blend file :) $\endgroup$ – Prasetya Putra May 30 '14 at 9:51
  • 1
    $\begingroup$ Works fine for me. Make sure you leave particle edit mode before rendering, other wise no hair will be rendered (this actually seems like a bit of a bug, you might want to report it if that turns out to be the cause). $\endgroup$ – gandalf3 May 30 '14 at 9:58
  • $\begingroup$ Ahhh, it worked. I feel really dumb by now. Btw, thanks gandalf3.. And i'm new to stackexchange, how do i close this questions so it wouln't make any incoveniences to the others? should I post reply saying it's already solved? $\endgroup$ – Prasetya Putra May 30 '14 at 10:03
  • $\begingroup$ I'm actually not sure if not rendering hair in particle edit mode is intended behavior or not. I filed a bug report, so we'll see what the developers say. If it is a bug, then it will be closed as off-topic as it's caused by a bug in blender (though it was a perfectly good and legitimate question, you did nothing wrong :). If it's intended behavior then I'll add a proper answer so others can find it more easily. $\endgroup$ – gandalf3 May 30 '14 at 10:42
4
$\begingroup$

Particles will not render in particle edit mode, due to a limitation:

This is intentional, it's a limitation in the particle system code that both Blender Internal and Cycles suffer from. Not considered a bug at the moment.

So make sure you are not in particle edit mode when rendering.


In case you are wondering what the suffering is about, blender's particle code is known to be inefficient and filled with issues. (I can't seem to find any sources for this, but I know I read it somewhere..)

A "looking into" is being talked about as part of the Gooseberry project, and a rewrite (with nodes support!) is also being worked on.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.