I have already searched for as many threads I could find to find a solution and tried them all as best as I could, but I can't make glass shader or Principled shader work with to make a transparent material resembling a realistic glass or clear acrylic. It almost always shows as completely black, or sometimes mirror-like

The most common solution to this was to increase bounce values, which I have done. I have also tried flipping and recalculating faces and tried different lights. The only closest material I can make to a glass is by using a transparent shader with a glossy one, but its result isn't satisfactory. The environment is set to black background, and setting it to any other colour just introduces reflection of that colour on upper half of the sphere.

enter image description here enter image description here enter image description here

  • 1
    $\begingroup$ It is very hard to tell what is going on here by just looking at the screenshots. Please share the .blend-file. $\endgroup$ May 9, 2018 at 7:03
  • $\begingroup$ The only way I can replicate this behaviour is by adjusting the properties of your floor to only be visible to the camera - so it's not interacting with the glass. This way only the world background is affecting the 'glass' and so it apears to simply be reflecting the background (but it's actually reflecting and refracting the background). $\endgroup$ May 9, 2018 at 8:36

2 Answers 2


Idk if this is the result you're looking for but this is the material I use.

enter image description here

  • $\begingroup$ It has more reflection and refraction than transparency for what I want, but more importantly the rendered result still shows completely black. But the rendered view is similar to your rendered view : i.imgur.com/jjArfue.jpg Does anyone have any idea what would be the cause of it? $\endgroup$
    – soslearn
    May 9, 2018 at 6:47

The culprit was "AO Bounce" setting. I had seen a Blender Guru tutorial which mentioned that for reducing render times, and had no idea it would have that effect on glass materials. Setting it to 0 fixed the issue. For now I have this setup, but it can use slightly more fresnel effect.enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.