1
$\begingroup$

I've got a game engine with working movement, camera controls, etc. I've added a model and parented it to a moving cube and it worked fine. Then i felt it was time to add some animation to the model. I made some working animations (running) and the animation itself works fine on the 3d screen when i play the timeline. It is saved as an action.

First, I select the armature itself, then open game logic. From there I set the controls up in this order. Keyboard as Sensor with W key as toggle ---> and ----> action "Player Walk" attached to "player walk" action animation. Set to start on frame 1 and end on frame 25 of the particular animation. Also set to -LoopStop-, blendin at 5, continue is checkboxed, priority is zero however i've set it at seperate values and no difference was made.

I go to play the game and the model that is parented to the moving cube works fine but the animation doesn't show. Even though the animation works perfectly on timeline. I've followed many tutorials to the best of my ability but I can't seem to make it work, not even when the sensor is set to always. Any help would be appreciated, I'm willing to attach a video if necessary.

$\endgroup$
1
$\begingroup$

The documentation says:

The Action actuator is only visible when an armature is selected, because actions are stored in the armature.

But this seems to be no longer true you can add the Action actuator to all objects this might cause the problem.

Try a setup like that (On your armature) with your start and end frame 1..25, Loop Stop (which actually means Loop Start -Play ipo continuously from start to end when a TRUE pulse is received.)

enter image description here

$\endgroup$
  • $\begingroup$ I've got nothing with it so far :\, Set up the same exact way. Is there any significance to the python text script or it's contents? I may record and link a video later to further show my difficulties, another point I'll add is that this model and armature were linked from another blender project to begin with, HOWEVER I can't get this to work in it's original project either and the model I'm using in the game engine blend was duplicated and moved. All the animations came with it and worked absolutely fine, only when i press P do they not play while the character moves. $\endgroup$ – Jason May 30 '14 at 15:00
  • $\begingroup$ @Jason Sorry for the confusion the script contained just a simple print("W") to make sure the keyboard sensor works. Thats because my setup didn't work also with logic nodes attached to the object itself. You could upload a simplified version of your (single) .blend file with only one action for further inspection at e.g. pasteall.org/blend $\endgroup$ – stacker May 30 '14 at 16:38
  • $\begingroup$ pasteall.org/blend/29531 Here's what I've got. In it there are 2 character meshes (one is obviously the player in the movement box, the other is on the side just for a reference). There are 4 actions made so far all of which are the same or empty (I named 3/4 empty so we could focus on the one labeled walk) When you press P, you can move around freely using WASD and +shift to run and space to jump as well as mouse camera movement. But as described nothing i do in game logic seems to make the character animate in game although the animation itself plays fine in the timeline. $\endgroup$ – Jason May 30 '14 at 19:47
  • $\begingroup$ The player also freezes in any frame it was last set in during the preview, as in if I stop the animation at 15 frames and hit play, he's stuck on frame 15 instead. Not sure if that has anything to do with it. $\endgroup$ – Jason May 30 '14 at 19:50
  • $\begingroup$ @Jason I removed the parenting to the box you can append this from your original file. The animation is now played when you hit 'W'. pasteall.org/blend/29533 $\endgroup$ – stacker May 30 '14 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.