0
$\begingroup$

I tried to set the origin point of my cube to be in its center by pressing CTrl+Alt+Shift+C and choosing "Geometry to Origin" but it changed the origin point only in Object mode... in Edit mode the origin point is still not set in the center of the cube. I want to set in the center so I can mirror the other half of my cube correctly with a mirror modifier. How the origin point is set in object mode: enter image description here

How the origin point is set in Edit Mode: enter image description here

$\endgroup$
  • $\begingroup$ Origin point is set only in Object mode because it's related only to object, in Edit mode you edit the meshes inside the object. Mirror modifier will work based on the origin point set in the Object mode. $\endgroup$ – Mr Zak May 8 '18 at 16:30
1
$\begingroup$

The origin of your object is where you put it .. you can still see it there, the dot in the center of the half-cube.

What's not where you want it is the 'Pivot Point for Rotation / Scaling', which you have set to either 'Individual Origins' or 'Median Point' (It's hard to tell from the picture - just to the left of the manipulator button). That, in either case, will be at your selected vertex, if you only have one vertex selected.

If want your transformation of elements to be centered on the object's origin while in Edit Mode, go into Object Mode, select the cube, and hit ShiftS > 'Cursor to Selected'. That will move the 3D cursor to the origin of the cube. Now, back in Edit Mode, select '3D Cursor' as the pivot for rotation/scaling, either by using keyboard . or selecting from this rollout:

enter image description here

In Object Mode, you can manipulate only objects, not their meshes, and their 'positions', for transformation purposes, are defined to be the positions of their origins.

$\endgroup$
  • $\begingroup$ How do I select '3D Cursor' as the pivot for rotation/scaling? Where do I find this setting? $\endgroup$ – T4yl0r May 8 '18 at 17:05
  • $\begingroup$ @T4yl0r .. I've expanded my answer $\endgroup$ – Robin Betts May 8 '18 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.