0
$\begingroup$

I have a model that has lots of animation clips(actions).

enter image description here

Before export as FBX, I set the pose to named "default" pose and exported as FBX like this.

enter image description here

But in Unity, it's changed to first animation clip in animation list in Blender!

enter image description here

I try to fix it, but there is nothing I can do. I can't change the order of animations in Blender and Unity either.

This wasn't first time, I had same issues before but I just ignored because it's fine in game play, but I really want to fix it this time.

What I want is set "default" pose in edit mode in Unity(not play mode). How do I set "default" pose as default, not first animation clip in the list?

Using Blender 2.78, and Unity 2017.3.0f3.

$\endgroup$
4
  • $\begingroup$ You can probably fix this by going to the import settings in Unity. As far as I recall you can choose which animation clips get imported and the order they get imported by doing this. I do not have access to unity at the moment so i cant test this.EDIT: By import settings i mean find the imported model in your object explorer in unity and there should be a place where you can modify how it is imported. $\endgroup$ – VampyreSix May 7 '18 at 13:56
  • $\begingroup$ If that does not work you might be able to adjust this by finding the animation controller object that is attached to the object and changing the list of animations that it has. $\endgroup$ – VampyreSix May 7 '18 at 13:58
  • $\begingroup$ @VampyreSix Yes, I can choose which animation clips want to import, but that doesn't change anything. Also I just change the order of animation clips to default to top but still have same result. Also setting in animation controller doesn't worked either. Editing animation controller not affects in edit mode. $\endgroup$ – modernator May 7 '18 at 14:47
  • $\begingroup$ @VampyreSix Also I can't change the order of animation clips in Unity directly, I had to remove some of them and add as new. I can't understand why Unity doesn't allow to change the order directly. $\endgroup$ – modernator May 7 '18 at 14:49
1
$\begingroup$
  • You should Know that Unity takes the "default pose" from the first frame of the first animation.

  • Also Unity classifies them as they are in blender:

enter image description here [Solution] 1 - Always create an Idle Animation and set the "default pose" in the first frame, and rename it to be the first animation.

or

2 - set "default pose" on the first frame of your first animation(action) in blender, so Unity can understand that's the default pose.

(don't forgit to Reimport the .FBX in Unity after making changes)

$\endgroup$
0
$\begingroup$

It's not clear solution, but there's a way to make animation clip top of the list by adding prefix something like "_". This is always work, however I hope that find better way.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.