1
$\begingroup$

In this model, I have used extrude, loop cut, inset for creating the model and the modifiers that I used was boolean, mirror modifier along the y axis and the subsurf modifier. The problem is why there seems to be a line between the mirror and the object where I lined it blue? Is there anyway to solve this ? At first, I think maybe there is a face between the model and the mirror but I have deleted it so I think the problem lies somewhere else.

I have made the vertices along the center and scale their 'y' location to 0. And I have found some problem that some parts of the meshes would go beyond the center even if I have already clipping turned on. I cannot find any face that is between the mirror and the model so I don't think that is the problem and I also have removed the doubles

my blender file

part of the meshes go beyond clipping example of the affected mesh unaffected part

the anvil model

the wireframe mode of the model

blue-lined model

$\endgroup$
  • $\begingroup$ Do you have 'merge' and 'clipping' options enabled in your mirror modifier? $\endgroup$ – ajwood May 7 '18 at 12:14
  • $\begingroup$ @ajwood I have enabled both 'merge' and 'clipping' in my mirror modifier $\endgroup$ – arcv May 7 '18 at 12:41
  • 2
    $\begingroup$ @arcv some parts of you second screenshot are surprising given that you have clipping enabled (e.g., the bottom-most vertex along the centre line is farther left than I would have thought possible). Try selecting all of the vertices along the center and scale their 'y' location to zero (sy0). Then set the object origin to (average location of the) select vertices. $\endgroup$ – ajwood May 7 '18 at 19:31
  • 2
    $\begingroup$ I think some of your vertices got past the clipping point before you enabled clipping. Now that you have clipping on, with the edge loop selected, grab/move them all back toward the correct side of the model. They should get "stuck" when they arrive at the axis of symmetry. $\endgroup$ – ajwood May 8 '18 at 12:12
  • 1
    $\begingroup$ In you attached .blend file, with the vertices you already have selected, go to right ortho view (numpad 3), and click+drag the green 'Y' handle to the left. $\endgroup$ – ajwood May 9 '18 at 0:29
0
$\begingroup$

Here's the answer to the problem. First, grab the center loop and move it towards the center till the clipping does not allow it to go any further. This makes sure that all of the vertices on the center loop are at the center of the model. Next, you must move the mirror modifier up above the subdivision surface modifier. This is a general rule of thumb that will remove the seam problem. Glad to be of help!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.