1
$\begingroup$

I can't select a bone on weightpaint. I have done some work with out a problems and just like that it stopped working.

In weight paint I can select a bone and it will show me the weight which is associated, have but I can't move it and rotate it, the armature is just orange-outlined.

How can i fix this? Keep in mined that I already tried opening and closing Blender

$\endgroup$
6
$\begingroup$

An orange outline indicates object mode selection for the armature. You want the armature in pose mode (blue select outline) before you start weight painting so that you can select and move the bones while you paint.

  • Select the armature and go into pose mode.
  • Select the mesh and go into weight paint mode.

When weight painting, the action mouse button setting makes a difference.

  • LMB LMB will weight paint

If you are using Select with Right -

  • RMB RMB will select a bone

If you are using Select with Left -

  • ⎈ CtrlLMB LMB will select a bone

While weight painting and the armature is in pose mode, G/S/R works with the active bone, not the object being painted.

| improve this answer | |
$\endgroup$
  • $\begingroup$ nice but does not work with Grease Pencil objects, I can't select them while in armature's pose mode... :/ (Blender 2.8.1 beta) $\endgroup$ – gordie Oct 22 '19 at 16:33
  • $\begingroup$ @gordie that appears to me as a bug. Weight painting a GP should work the same as a mesh. $\endgroup$ – sambler Oct 23 '19 at 2:46
  • 1
    $\begingroup$ Submitted bug T71035 for this. $\endgroup$ – sambler Oct 23 '19 at 3:14
  • $\begingroup$ Turns out this is an unimplemented feature waiting to be worked on. $\endgroup$ – sambler Oct 24 '19 at 1:36
3
$\begingroup$

Deselect the options shown below. It worked for me. enter image description here

| improve this answer | |
$\endgroup$
2
$\begingroup$

edit, found the problem, i had the paint mask set to face selection for painting (basically the mode that lets you only paint on areas that are selected in edit mode first) - with this mode on you can't select bones so you need to turn it off first, control click the bone you want to weight paint, then turn the paint mask back on

| improve this answer | |
$\endgroup$
1
$\begingroup$

Two things. Make sure that your armature is in "Pose Mode." Select the armature and set it to pose, then hold shift and select the mesh also. Then go straight into weight pain. If that doesn't work there is a bug where Blender does not let you select bones if you started the file with an older version of Blender. You then must start a new file in Blender and append everything. You can select multiple items at once and append them all at once so it's not as tedious.

| improve this answer | |
$\endgroup$
1
$\begingroup$

Solved my issue. I was not able to select any bones to paint in Weight mode, blender (2.8) because my model was HIDDEN inside EDIT mode.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Had the same type of problem, in Paint Mode bone wouldn't select even with Ctrl. In Pose Mode bones wont selected, maybe something is wrong with Blender.

Try to:

  1. Save file
  2. Restart Blender
  3. Append from saved file into new scene

In my case problem was solved

P.S. Faced with this problem again. And problem was solved with other method: Be sure what "Toggle X-Ray" button deselected (Off) in Pose Mode

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.