3
$\begingroup$

In Blender 2.79b, I'm trying to render this motion tracked scene with a simple cube then a plane as a shadow catcher. But when I render it, the shadow catcher is invisible but seems to be brightening the area it is in. You can clearly see it with the bright square under the cube. I'm pretty new to Blender so all help is welcome.

I cannot figure out what's causing this.

photo1

The scene in 3D viewport:

scene

Node tree:

enter image description here

$\endgroup$
9
  • $\begingroup$ Could you show your compositing nodetree? $\endgroup$ – Carlo May 6 '18 at 1:28
  • $\begingroup$ is film>transparency enabled (i.stack.imgur.com/yR1He.png)? How are you compositing the rendered image on top of the video? Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information on how you set up your project. $\endgroup$ – user1853 May 6 '18 at 1:37
  • 1
    $\begingroup$ @cegaton Thank you so much! That seemed to fix the problem. $\endgroup$ – bmanner May 6 '18 at 14:38
  • 1
    $\begingroup$ @bmanner can you please write an answer detailing what you did? It might help others that have a similar issue. Please read: blender.stackexchange.com/help/self-answer $\endgroup$ – user1853 May 6 '18 at 15:16
  • 1
    $\begingroup$ @cegaton Will do! $\endgroup$ – bmanner May 6 '18 at 15:44
2
$\begingroup$

I came across this thread when searching for a solution to the same exact problem as the OP. I tried various fixes, included the "simplified" node set up mentioned above by cegaton. Nothing worked.

The node setup posted by bmanner is the same node setup I get when I use a shadow catcher plane in Blender 2.79b (Mac version). I'm a rank beginner with nodes, so reducing the three "inputs" down to the two shown in the fix was not working for me.

Through all the playing around, however, I did find a very simple fix. By checking the "clamp" checkbox in both of the "add" nodes, everything renders properly. The shadow catcher no longer brightens everything it touches. No other aspect of the scene seems to be affected in the render. No idea why or how this works, but it does.

I realize this is an old thread. Since I haven't seen this solution anywhere else, I figured this would be a good place to mention it. The OP's screen shot is attached, with the boxes noted. I hope this helps someone.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.