1
$\begingroup$

This question already has an answer here:

When I try to render my scene, there are no Lights at Final Render.

enter image description here

But if I use Shift+Z shortcut to see a preview, all works fine.

enter image description here

I really don't understand what is going on... Can you guys help this newbie? I installed Filmic Renderer that BlenderGuru recommended. Other than that, everyting are default, I think.

$\endgroup$

marked as duplicate by Crantisz, David May 7 '18 at 13:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ Are the lights in a layer that is not part of the render layer? $\endgroup$ – cegaton May 6 '18 at 0:10
  • $\begingroup$ They are in the same layer. I mean interior lights are. The one behind the windows are in 3rd layer. $\endgroup$ – Huseyinekrem May 6 '18 at 5:55
  • 1
    $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information on how you set up your project. Add images that might help us understand your scene and settings. Consider sharing your .blend file so that others can inspect it. You can upload it at blend-exchange.giantcowfilms.com and then paste the resulting link as part of your question. $\endgroup$ – cegaton May 6 '18 at 15:54
  • $\begingroup$ I did that, lets wait.. $\endgroup$ – Huseyinekrem May 6 '18 at 19:56
  • $\begingroup$ Odd, the lights don't show up in the preview/viewport render for me. That said, the reason the lights aren't showing up in the final render is because layer 3 (the layer with the lights) is not enabled in the renderlayer (as cegaton suggested) $\endgroup$ – gandalf3 May 6 '18 at 21:55
2
$\begingroup$

Your lights are not in the same layer.

They are in a layer that is not set to be rendered.

enter image description here

Once you enable the layer that holds the lights along with the one that holds the rest of the scene you will have lights...

enter image description here

Rendered image with both layers enabled

enter image description here

Alternatively you can set the lights to be active in more than one layer.

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.