1
$\begingroup$

I want to do a 2d animation of a particle system.

I created a background, put my camera up, set the mode to orthographic.

I created an object for my particles to use, set them shaderless, created a particle system and chose that object to be rendered.

camera, material and particle properties

(camera, material and particle properties)

When I view the animation through the camera it looks nice but when I render the animation, it takes a lot of time and the image comes back just black.

viewport vs render

(viewport vs render)

I tried putting up a light, but that didn't work.

blender project file

$\endgroup$
  • 1
    $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add images that might help us understand your scene and settings. Don't rely on others downloading your project just to understand your question. Please read: blender.meta.stackexchange.com/questions/2449/… $\endgroup$ – cegaton May 4 '18 at 5:45
  • $\begingroup$ Switch to blender render then use the same node setup and it should work. $\endgroup$ – Treehee May 4 '18 at 9:54
  • $\begingroup$ I can't switch to blender render because I need the particle info node for the particles to fade in and out. $\endgroup$ – Benni May 4 '18 at 10:18
1
$\begingroup$

It's not going to work because of child particles

Unfortunately, since you are rendering child particles, you can't achieve your goal at the moment (Blender 2.79).

This is because the Particle Info node

... currently only supports parent particles. Info from child particles is not available.

I don't know the roadmap for this.

Other details

First, you are currently seeing a good "material" view, because it doesn't rely on Cycles. But if you change to the "rendered" view (you don't have to make an actual render, but it's practically the same), it falls back to black.

enter image description here

Now, even if you disable the "children" in your particle system, it's not going to get any better

enter image description here

this is because your material is, indeed, "shaderless"!

If you add a shader (like the "Emission Shader"), though:

enter image description here

Voilà!

Unfortunately, though, it won't work if you enable child particles again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.