0
$\begingroup$

I started out with an ordinary rigged human character model, complete with vertex groups and correct weights.

Then I did some geometry modification. I had to reassign the vertex groups and that understandibly wrecked the weights.

So the idea was to transfer the weights from the old mesh to the modified mesh. I put the meshes on top of each other and did everything to the book, selecting the source first, then the destination, entering weight paint and hitting weights transfer.

At first it looked great, with all the correct weights in place on the destination mesh.

Then came the shock. I noticed that all vertex groups in the destination mesh had been altered such that every single vertex group whether affected by the weight change or not now comprised all vertices of the entire mesh. Of course that renders the mesh unusable.

I tried all different options in the weights transfer operator, to no avail.

Parenting the source mesh to the destination armature didn't help either.

What could be the problem. I am at my wits end.

$\endgroup$
  • $\begingroup$ So all vertices are in all vertex groups, but is their weight appropriate (eg 0 where there should be none) or is the weight value wrong as well? $\endgroup$ – kheetor May 2 '18 at 8:28
0
$\begingroup$

You can use the weight tool Clean to fix that. It will remove from the group, every vertex with a weight under the specified threshold.

To remove every vertex with weight 0, from each vertex group :

  • Subset : All Groups
  • Limit : 0
$\endgroup$
  • $\begingroup$ that solved the problem, thanks again ... $\endgroup$ – iblok May 2 '18 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.