2
$\begingroup$

This question already has an answer here:

Trying to render the default scene. Have set my user preferences to have Render Output go to F:\Blender\BStills\ - and this is what's listed in Properties panel as well.

If I try to render an animation, things work fine. If I try to render a single, still image, I'm not getting any output (even though the render looks like it runs fine within blender).

Also, is there a simple way to attach .blend files so people can look at those directly to help with troubleshooting?

Thanks for any help.

$\endgroup$

marked as duplicate by Mr Zak, Ray Mairlot, Scott Milner, Duarte Farrajota Ramos, Community May 2 '18 at 17:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ You can edit your question and add the link from this site which allows to upload blend files blend-exchange.giantcowfilms.com $\endgroup$ – lemon May 1 '18 at 16:00
  • $\begingroup$ Ok - thanks - trying to upload my blend file. Title shows up (testRender.blend) but so far not seeing the progress bar advance on either Firefox or Google Chrome (over 10 minutes on Chrome so don't think it's working) $\endgroup$ – Rob May 1 '18 at 16:17
  • 2
    $\begingroup$ This is expected behavior. Output path is only used for animations as far as I now, stills aren't saved to disk automatically, if I'm not mistaken. $\endgroup$ – Duarte Farrajota Ramos May 1 '18 at 16:19
2
$\begingroup$

If you render using F12 or the Render button, the image doesn't get saved automatically (I don't know why the deveolopers made that choice).

You can manually save the rendered image in the UV/Image editor Pressing F3 (or "save as image" on the menu).

To auto-save a rendered image in the format specified in the ouptut settings, you would need to press the Animation button (or Ctrl+F12).

Just remember to set the frame range so that it renders only one frame and not the default 250.

$\endgroup$
  • $\begingroup$ Ah - in order to upload blend file, you have to include the URL of the question down below file! Once I did that, uploaded instantly. $\endgroup$ – Rob May 1 '18 at 17:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.