1
$\begingroup$

I imported a model from blender to unity as an fbx file, but for some reason it looks different. I don't know how to really describe, so have some pictures:

Column in unity: enter image description here

Column in blender: enter image description here

And setting the mesh to smooth shading in blender makes it even worse:

Column in Unity: https: enter image description here

What can I do to make this look better? Is there a trick to have the model seem as sharp as in the blender preview?

$\endgroup$
2
$\begingroup$

In Unity, pay attention to the color of the Sun lamp and match it to what you had in Blender. In Unity the result currently looks tinted towards green. This could also be because of the sky which constitutes to the color as well.

Texture definition is another probable key issue. Depending on how optimal your UV layouts are, you should be getting good results using high resolution textures like 2048 x 2048. In Blender you could bake the textures at 4k or 8k resolution, Unity by default imports images as 2k textures. You can adjust this per texture in the import options, so make sure it's currently not bottlenecking your quality if your textures are otherwise high quality. From the images it's not apparent but make sure to bake normal map and apply the normal map texture to your Unity material. When using a normal map, your model should always be set to smooth shading.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.