3
$\begingroup$

I am currently sculpting a mesh with 500,000 triangles; the object mode has very noticeable lag but sculpt mode is a silky smooth 60 fps. This is very unusual and I don't know why it is doing this. Fast navigate doesn't make any difference to object mode's frame rate.

I thought changing the view clip end to 50 and removing both the camera and lamp from the scene would speed things up but, while it did temporarily get me 60fps, when I clicked on the character the lag starts up again. When I click on an object such as a cube I get full frames but clicking back on the character slows things down.

Why is this happening and how can I speed up the FPS?

$\endgroup$
  • $\begingroup$ How many different objects are there in the scene? How many meshes does the object you try to sculpt consist of? $\endgroup$ – Mr Zak Apr 25 '18 at 15:51
  • $\begingroup$ It consisted of a single character mesh and nothing else. Just 1 object. $\endgroup$ – Emerald Eel Entertainment Apr 25 '18 at 19:31
  • $\begingroup$ Interesting, I can't get that on my end while my hardware isn't recent. The only thought I have is when object is selected then Blender draws wire of its faces (even if wire is unchecked) and some options pertaining to Object mode which is not present in Sculpt mode. Though wire is known to have little to no difference in performance so this is quite unlikely. Try appending object into another project and testing, if nothing comes up then either report a bug (and you'll need to share some file) or just stick with how it works so far $\endgroup$ – Mr Zak Apr 26 '18 at 22:10
  • $\begingroup$ I created a new object in the shape of the character I made previously and detail flood filled it to 400,000 triangles and it still lags, even with wire unchecked in the object tab. I also remeshed the sculpt to have only quads and it still lagged. $\endgroup$ – Emerald Eel Entertainment Apr 28 '18 at 9:30
1
$\begingroup$

Two possibilities:

  1. If you have hidden most parts of the mesh in sculpt mode (H), these faces will be visible in object mode.

enter image description here

  1. If you are using a multiresolution modifier, you can set the preview subdivisions higher than sculpt mode.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ 1) I have backface culling enabled and 2) I used dyntopo. $\endgroup$ – Emerald Eel Entertainment Apr 25 '18 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.