0
$\begingroup$

I am pretty new to Blender but with tutorials I came at least this far.

I made a mesh blanket over a mesh bench. I used cloth simulation to make the blanket a nice fit and at the frame I liked I used Apply under the Moderfiers tab in Properties ,to make the cloth a mesh.

This is the front of the blanket and then the back with Solidify applied:

Front

Back

But when I try to upload it into my virtual world, the back is still blank:

inworld

$\endgroup$
  • 3
    $\begingroup$ To me, it looks like you've exported the mesh without applying the solidify modifier before the export (or checking some export option that does it automatically). $\endgroup$ – lemon Apr 24 '18 at 17:38
  • $\begingroup$ I didn't export it without the solidify and i wouldn't know about any export options to check $\endgroup$ – Siara Apr 24 '18 at 17:52
  • 1
    $\begingroup$ There is also potentially a problem with the normals already in Blender. Try enabling "Backface Culling" in the 3D view properties --> Shading --> Backface Culling to see if that hides it as well. $\endgroup$ – JakeD Apr 24 '18 at 17:53
  • $\begingroup$ If you aren't uploading as a .blend file, you will see something like this in the export settings. $\endgroup$ – JakeD Apr 24 '18 at 17:55
  • 1
    $\begingroup$ The mesh was seen-through because it hasn't had any thickness. As normals by definition can point only one side those faces aren't seen from another side in the engines which can't do that (e.g. game engines). As Solidify is Blender modifier game engine isn't aware of it, you have to apply the modiifier to make geometry real $\endgroup$ – Mr Zak Apr 24 '18 at 18:29
2
$\begingroup$

You must either apply the modifier manually or enable "Apply modifiers" in the export settings for whatever file type you are exporting to. For Collada, the setting is here:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.