1
$\begingroup$

I am doing a Blender tutorial from Blender Guru on How to Build a City (https://www.youtube.com/watch?v=XCEN0qQOsIA) and I'm around the 30 minute mark where you insert your buildings as a group particle system. Many problems arised once I did so, for starters the buildings were emitting the wrong side of the plane (through the bottom), I fixed this. The buildings were also still overlapping even after I unchecked random, I fixed that as well. Now there's only one problem I can't seem to fix. The particle system of the buildings is emitting the proper way (upwards out of the plane), but they are still upside down (on themselves). Picture down below (first picture shows the top, where the entrance is, the second pic shows the roof with all the addded details on the plane that I'm emitting my particles from):

Building upside down when emitted with a particle system

Underside of plane, where we can see that the roof is at the bottom

I've tried messing around with the majority of the particle settings but an't seem tto figure it out, the closest thing I could get was under the rotation tab and messing with the phase, but thiss turns the particles around the plane, not on itself. Any help would be appreciated! Thanks!

$\endgroup$
  • $\begingroup$ make sure you have the correct orientation drop down. Rotation>Initial Orientation> Global Z (or any that may work) You may also need to correct your initial group, you may have inverted them incorrectly. Go back to your group of buildings and rotate them correctly, You may need to apply scale (CTRL+A) $\endgroup$ – icYou520 Apr 24 '18 at 19:49
  • $\begingroup$ Yes I tried all of the orientations. Object Y is the only one that gives the closest result. I made sure that my building group was also properly rotated on it's own layer. I will try the scaling. $\endgroup$ – Fireguy Apr 24 '18 at 21:22
  • $\begingroup$ if you want to attach your blend file, I can take a look and try to figure it out $\endgroup$ – icYou520 Apr 24 '18 at 21:31
  • $\begingroup$ blend-exchange.giantcowfilms.com $\endgroup$ – icYou520 Apr 24 '18 at 21:34
  • $\begingroup$ Here you go! Hopefully it worked! It's my first time using this website! Thanks for the help! $\endgroup$ – Fireguy Apr 25 '18 at 18:23
1
$\begingroup$

Ok I took a look at your file, You had to fix the rotation of two things.

  1. Change the rotation for the particles to Global Z

  2. Go back to your other layer and rotate the group as shown in the image

  3. You had the pivot point at the top of all your buildings, So Blender assumes this is where the building should start. You need to select each building in edit mode, then select the bottom face, hit Shift + S and choose move cursor to selected. Hit tab to go back to object mode and on the left tool bar change pivot point to 3D cursor.

You need to do this to every building in the group.

enter image description here enter image description here enter image description here

Or you can just use the fixed blend file.

$\endgroup$
  • 1
    $\begingroup$ Thank you so much! I tried messing around with the buildings in their own layer but never thought of the pivot point. I didn't think my Object Y rotation was a problem since that's what the guy in the tutorial selected. I rather try to learn it on my own so I'll do all your steps, thanks! $\endgroup$ – Fireguy Apr 26 '18 at 16:51
  • $\begingroup$ Glad I could help, Feel free to accept the answer so it can help others in the future. $\endgroup$ – icYou520 Apr 26 '18 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.