I am having a big problem creating an outline mesh around a number of edges.

I found a lot of solutions to that topic like extrude along individual normals (after creating faces) or using the mesh-offset-plugin but all solutions I found so far do not work the way I would them expect to work.

eg How do I Inset a face equally? and How to offset the edges?

The following screenshot shows my problem:


The top object is my source where I want an outline object... Or just another object where all points have the same distance to the origin.

The second object just shows the result of an extrusion along the z axis where the distance on the hitches are too small..

The third object shows my "normal" results using any of the hints google shows me... including the result of the mesh-offset-plugin... the hitches are to big compared to the "flat" faces...

The last object at the bottom shows the result I created in 2D with corel draw and 2 mintues time... (the reimport through Inkskape Import and Export to blender took a little longer...)

Using the Inset toolset did not work the way I want nor the shrink/fatten tool nor the extrude individual faces does the job...

A possible but very unsatisfying solution is to first extrude along the y-axis to get faces instead of edges and then extrude every single selected face by an identical amount using "e" to extrude and "1" for the distance of 1 eg.


After that I have to delete and merge all the new overlapping vertices in order to get the outline I wanted... And even that does not rally work the way I wand becaus extruding the faces on the sides does not extrude orthogonally to the face but somewhere else...

What am I missing here? I thought of a problem of the direction of my normals but did not find any possibility to make the orthogonal to the face they are connected to...

Thanks for your thoughts!

Update / Edit:

Here is what I got from the skin modifier:


I really have no idea what the problem is... I think maybe my line is the problem... here is a blender file with the line I am trying to outline:

Edit: finally ;-) THANKS very much for the hint with the wrong scale in my line... that was the problem which caused every solution to fail!

  • $\begingroup$ Have you tried the Skin modifier? The skin modifier automatically generates geometry around mesh edges to specified distances. $\endgroup$ Apr 24, 2018 at 8:26
  • $\begingroup$ The skin modifier creates more or less the same structure as number 3 in my first screenshot... It also seems to extrude along individuals... So yeah I tried but it did not work... ;-) $\endgroup$ Apr 24, 2018 at 8:30
  • $\begingroup$ Convert to curve and use "Extrude" in the "geometry" section? $\endgroup$
    – lemon
    Apr 24, 2018 at 8:42
  • $\begingroup$ @StefanMöller I don't get the same as your 'number 3' and I don't really understand what you mean by 'extrude along individuals'. I've added an answer along with an image to show the result I get with Skin - please explain what is bad with this. $\endgroup$ Apr 24, 2018 at 8:44

2 Answers 2


Considering the base shape has no surface and is edges only, you can convert it to a curve with AltC, then use the "extrude" parameter:

enter image description here

Doing that the distance from the outer edges to the base vertices is constant.

Edit: in meantime I've downloaded your file. From both solution the problem is your shape is scaled. So you need to apply scale CtrlA before any other thing.

  • $\begingroup$ Great spot with the scale - that certainly explains the issue. $\endgroup$ Apr 24, 2018 at 9:17
  • $\begingroup$ Yeah.. thank you so much... I am new to blender and try to model things for my 3d printer... and that issue took me hours... did not know that these scale things affect everything so hard... $\endgroup$ Apr 24, 2018 at 9:19
  • 1
    $\begingroup$ Scale and rotation can often cause issues, when something is weird you should always think about them $\endgroup$
    – lemon
    Apr 24, 2018 at 9:21

The Skin modifier can be used to build geometry around mesh edges, controllable via the Mean Radius settings in Edit mode. Setting the Mean Radius to the same value for all vertices should produce an evenly distanced surface.

skin modifier animated


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .