1
$\begingroup$

I am trying to do a simple simulation of crushing a can between a plane and a can crusher. The can crusher and planes are collision objects and the can itself has soft body physics on it. I have tried recalculating normals, adjusting inner and outer settings on the collision objects, I've messed with the order of modifiers that I put on the can, I've applied location, rotation, and scale, the objects are on the same layer etc. Also, I uploaded a gif. You notice right away that the object disappears which I couldn't figure out either. Is there something I'm missing here which is making my simulation not work?

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Decreasing the bending property to below 5 helps. $\endgroup$ – Leander Apr 24 '18 at 20:10
  • $\begingroup$ I edited out the "thanks in advance" - on Stack exchange, there is no need to thank someone in a post, or in the comments. Accepting their answer shows that it helped, and you can also upvote. I also removed the "I attached the blend file." The fact that you have the "Download the .Blend" link makes it obvious that you added the blend file :) $\endgroup$ – X-27 Apr 29 '18 at 19:14
2
$\begingroup$

See this answer. Looks like a similar thing is happening to your mesh. If you check the dimensions in the properties panel you'll see the values go crazy once the can disappears.

Removing the softbody modifier and re-adding a fresh one stops the disappearing act, and it doesn't look like you have any overlapping geometry. I think it's something in your softbody settings, in the Soft Body Edges section. It looks like you've tweaked that quite a bit; perhaps you've pushed it to its limits.

$\endgroup$
  • 1
    $\begingroup$ Hey thanks for the answer @wysiwyg. I actually ended up using the same settings but I basically eased the simulation into those settings instead of just starting with the highest settings on everything. So I did push it to its limits initially and tweaking it helped. Thanks for the help man $\endgroup$ – Tyler Dahl Apr 24 '18 at 20:13
  • $\begingroup$ No problem, glad you figured it out. $\endgroup$ – wysiwyg Apr 24 '18 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.