screenshot of Blender: some circle shows up when I try to rotate a cube

I don't know any shortcut, and I can't rotate the view anymore. If I rotate, some circle shows up. Previously, before I couldn't rotate anymore, the circle did not show up. I tried reinstalling the software and it still happens.

Edit: I'm sorry, I had problems with my middle mouse button, which didn't work correctly anymore. I changed the mouse and now it's working.


closed as off-topic by JakeD, Duarte Farrajota Ramos, iKlsR Apr 24 '18 at 12:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is too localized in its current form and is unlikely to be applicable outside of a very narrow context. Consider broadening the scope of this question in order to make it more useful for future users of the site." – iKlsR
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ You are not rotating the view, you are rotating an object and you seem to have proportional editing turned on. $\endgroup$ – Duarte Farrajota Ramos Apr 23 '18 at 16:16
  • $\begingroup$ if i rotate view its cant rotate, can help me?? i do load factory setting, and its works, but cant rotate view again, its some bug?? $\endgroup$ – ilman akbari Apr 23 '18 at 16:25

That circle appears when you are using proportional editing. You can't edit and rotate or navigate at the same time. One you are done executing whatever transformation you are doing, then you will be able to navigate.

A way to exit the tools in blender is by pressing the Esc key.

The same applies when you are using circle select (keyboard shortcut C), box select or lasso select. Selection tools will not let you rotate until you are done selecting. Press escape to exit selection and then navigate in the viewport.


Not the answer you're looking for? Browse other questions tagged or ask your own question.