2
$\begingroup$

My computer has 8 GB RAM but is not able to render a 720p 2D video in Blender but my older computer was able to render much heavier videos, having only 4GB Ram; I was running Windows and Sony Vegas then but my new system is running on Linux.

I wonder if I must be doing someting wrong on my render settings, or if not, if there is another way of editing not heavy videos using Blender running on a pc with about 8gb RAM.

Please watch my video, at least some of it in which I explain my problem https://www.youtube.com/watch?v=YKqcFmzKE5M if you need any additional information.

$\endgroup$
  • 2
    $\begingroup$ On the User Preferences, System tab there should be a 'Sequencer/Clip Editor' setting - what is that set to? On my system it seems to be defaulted to 1024Mb (ie, 1GB) and this should limit how much memory blender allocates to the video sequence editor. $\endgroup$ – Rich Sedman Apr 22 '18 at 21:48
  • $\begingroup$ Do you mean I should increase this value? (Hope I understood ir right) $\endgroup$ – monsieurjean Apr 24 '18 at 7:06
  • $\begingroup$ Not increase - but possibly decrease. From your video Blender appears to be using all of your physical memory (8Gb) along with all of your free swap - so upwards of, say 12Gb. The parameter is to limit the amount of memory allocated in certain situations so if it's already set to 1Gb then it's obviously not doing its job - or the memory is being allocated by something not covered by that parameter. If, however, it's currently set to, say, 20Gb then that could certainly be a cause and dropping it to, say, 4Gb (half your physical memory) might help. $\endgroup$ – Rich Sedman Apr 24 '18 at 7:37
  • 1
    $\begingroup$ I opened the User Preferences > System and noticed that my "Sequencer / Clip Editor:" was set to 24273 ! I will change it to something about Gb and tell you the results. Thanks $\endgroup$ – monsieurjean Apr 24 '18 at 13:28
  • 2
    $\begingroup$ Thanks a lot! my problem is solved! I changed the "Sequencer" to 2048. The video was rendered completely and my computer didn't crash. But this "Sequencer / Clip Editor" Field seems to be the ammount of memory which is NOT used during the rendering. During rendering I opened the System Monitor, and noticed that the memory usage, never exceeded 5,3 of my 7,3 GiB Ram. It seems that this 2Gb that I set, are the amount of memory which is left to be unused. Strangely my Swap memory wasn't used at all during all the time. But anyways. thanks a lot! $\endgroup$ – monsieurjean Apr 24 '18 at 13:54
1
$\begingroup$

Blender include a setting in the User Preferences/System tab to limit the amount of memory that the Video Sequence Editor can use. This setting should be never set to more than your available system memory plus the available swap - otherwise Blender can attempt to grab more memory than is available and cause the system to crash or become unresponsive.

At the bottom of the System tab in User Preferences is a 'Sequencer/Clip Editor' setting that dictates the memory limit for blender when caching and rendering videos in the VSE. This setting normally defaults to 1024Mb - ie, 1Gb - and so should not cause a problem (unless your system has less than 1Gb of available memory). If this is set to a value that is larger than your system memory - or less than your 'free' memory when Blender is not running - then you may get Blender trying to allocate more memory than is available.

Reduce the value to limit the amount of memory available to Blender.

|improve this answer|||||
$\endgroup$
0
$\begingroup$

I am also not very expert in blender but i noticed a couple of things that can work for u i think, 1. Render animation frame by frame by selecting a folder and select output as any image type. And i think this is the main cause of crashing .

I think this will solve your problem . but still there is some thing that u can do. 2. Under the performance tab change the till size to 16×16 if u are rendering by cpu and for graphics card i think its 256× 256 ( not sure check google )

3 You can reduce samples

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.