1
$\begingroup$

I have used the sapling tool to build a tree for myself. I would prefer not to convert the curve to a mesh to make life simpler if I want to modify it later.

I added a texture and adjusted the scaling so it looks correct with the 'Mapping' section of the 'Texture' tab. When I export the model as a .obj and load it in to opengl, the texture coordinates are all wrong, they are so distorted! I assume the scale factors I have set in the mapping section are not being accounted for in the exported file? What should I do?

Is there any way to see how blender has UV unwrapped this mesh (without converting the curve to a mesh?). The texture mapping is not perfect and it would be nice to edit it a little! My model

$\endgroup$
1
$\begingroup$

Turn on "Use UV for mapping" in the texture space options in the Object Data tab of the properties window:

enter image description here

Turning on this option will generate UV maps for when you convert the curve to a mesh, or export the curve to .obj, since .obj doesn't support bezier curves and converts the curve to mesh as part of the export process.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thanks for the response, I have been doing this, but still when I import the .obj file in opengl the texture is scaled incorrectly. I noticed that my 'size' fields (just under the UV for mapping checkbox) for x, y, and z are not 1.0. would this be an issue? $\endgroup$ – Harrison Vince Apr 24 '18 at 8:55
  • $\begingroup$ My guess would be that the disparity comes from using something other than UV coordinates to map the textures in blender. You may find that you have to convert to mesh and adjust the UVs by hand to get the result you want. $\endgroup$ – dixiepig May 3 '18 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.