1
$\begingroup$

I am creating a year-long time lapse, with one image taken at exactly the same time each day. However, due to changing memory cards changing the position of the camera by a small amount, many of the photos have a shift. I have tried carefully putting tracking markers and using 2D stabilization. However, the final rendered video still shows some jerky camera movements, as the distance between two consecutive frames is too large for the smoothing to take effect.

The frustrating thing is that in the "movie clip editor", some of the "Display" options allows for "Lock to Selection" and "Display Stabilization". When these options are ticked, the preview movie is beautifully centered and stable around one node in the center. However, there is no way to render this movie, as they are not part of the "2D Stabilization" node.

How can I render the movie with the camera locked to one of the nodes? The effect would be similar to a recent gif floating around the web of Emilia Clarke's stabilized eyebrows... Many thanks!

EDIT: @3pointedit: I am using 6 points. As I understand it, for my issue, it doesn't matter how many points I use, as the problem is that the image would be very stable for about ~10 frames (where the camera was still), then the next frame would be noticeable off (after I changed the card on the camera, but didn't set it back exactly in the same position). Hence, no matter how much the software wants to "stabilise" (interpolation or whatever), the 11th frame would noticeably jump. What I want is for every single frame to have the one designated marker in exactly the same position. Other markers can help in rotation stabilisation, etc.

Sample of jump:

EDIT: Jumpy1

The white box is the designated marker that I want to stay on the one spot. As you can see, the track path will jump towards the right in the next frame (just above the "E" in TELUS). This tends to happen throughout the timelapse.

Sample of settings:

Settings1

As you can see, I have "Lock to selection" ticked. This means that during the preview, the video behaves as I would like it to; the marker above stays on the same spot on the screen. However, during rendering, it does not.

Sample of 2D Stabilization settings:

Settings2

I've tried futzing around with the various markers, autoscale on/off, etc, but to no avail.

Nodes settings (very simple and straightforward): Nodes settings

Thanks very much for your time and wisdom; I appreciate it.

$\endgroup$
  • $\begingroup$ Screen shot of your settings would help. But the image lock to a single tracker should be the same in 2D stailize. How many trackers are you using? $\endgroup$ – 3pointedit Apr 20 '18 at 6:29
  • 1
    $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information on how you set up your project. Add images that might help us understand your scene and compositor's settings. $\endgroup$ – user1853 Apr 20 '18 at 7:38
  • $\begingroup$ Could you show your marker's Graph for all the interested markers? Wouldn't it be possible that some tracking errors occoured and you need to pick differnet fatures points/adjust manually? $\endgroup$ – Carlo Apr 21 '18 at 23:12
1
$\begingroup$

Trackers are uniquely associated to the tracked shot.

In order to stabilize you need to select the clip you are using as source.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks Cegaton, that kinda pointed me to the right answer. After doing the fix you suggested, I found that I needed to have "Display stabilization" checked in "Display" and I needed to be very selective with the rotation markers. Also, to have "autoscale" unchecked. Tutorial videos can be quite handy, but the sequence of buttons pressed or which ones pressed can seem to be off the cuff or optional, but instead they can be vital. Thanks for your time and patience. $\endgroup$ – Erk Apr 23 '18 at 6:05
  • $\begingroup$ Display stabilization is only to display in the movie clip editor and has no effect on the stabilzation using the compositor. $\endgroup$ – user1853 Apr 23 '18 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.