3
$\begingroup$

I started rendering with Branched Path Tracing after learning about the benefits. However, after waiting for hours for a render to finish, the renders always end up with some blocks looking like they completed and then some MUCH more grainy (like they didn't complete...however the process does complete 100%). See images here. Am I doing something wrong?? This seems like a clear bug.

You can distinctly see the clearer blocks vs the ones that look like they had way less passes. I still don't understand how this makes sense.

enter image description here

enter image description here

Edit: Tiles are 256 X 240. I am using an iMac 2017 with 4.2 GHz Intel Core i7, 40GB RAM and AMD Radeon Pro 580 8GB. I know AMD cards aren't the best for Blender but it works totally fine outside of Branched Path Tracing. I am also using the latest daily build and using CPU + GPU...could that be it? I haven't tried in 2.79b because CPU + GPU is just so much faster for me.

$\endgroup$
  • $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information on what kind of hardware you are using and the size of your render tiles. $\endgroup$ – cegaton Apr 20 '18 at 7:37
  • 2
    $\begingroup$ Are you using Denoising? $\endgroup$ – kheetor Apr 20 '18 at 7:57
  • $\begingroup$ I am not denoising here at all, no. This is with denoising turned off. $\endgroup$ – spenrobert Apr 20 '18 at 15:51
  • 1
    $\begingroup$ Those look like some tiles were rendered on higher quality while others on lower, the area of clear render is a bit bigger than where arrow is pointing to, I took the liberty to encircle it on a screenshot. Did you try changing tile size a bit? Though Blender doesn't render different tiles of different quality afaik so this looks like a bug. Pobably due to GPU rendering $\endgroup$ – Mr Zak Apr 20 '18 at 16:17
  • 1
    $\begingroup$ Too many variables, you will have to debug one by one . Start by using a release version (not a daily build). This looks to me like an issue with the GPU, try rendering on CPU only and see if the problem occurs. Then render with GPU only. The tile size might be an issue as well if combining CPU and GPU, as GPUs work better with large tile sizes and CPU with smaller. $\endgroup$ – cegaton Apr 20 '18 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.