0
$\begingroup$

This question already has an answer here:

Alright, so I have no clue what's going on here... The project was perfectly fine, I saved, closed Blender, reopened the project in Blender, and now I'm having all these problems with it. The file is important to my problem because I'm not having this problem with any other objects I make, in either the same file or a different one.

So here's a link to the file:

.

And here's a screenshot:

anvil_scene.blend screenshot

So the first problem is, if I right click on the anvil to select it (or left click in my case, because I switched the left and right click assignments), Blender crashes. I've tried running Blender from the command line and when it closes out after trying to select the anvil it says: error: EXCEPTION_ACCESS_VIOLATION.

The second weird thing is that I can't leave Object Mode. If I make another object and select it I can enter Edit Mode just fine, which is normal, but if I press a when looking at the anvil in Object Mode, it gets this orange outline around it, instead of the usual yellow, and I still can't leave Object Mode, and Blender is acting as if the object isn't selected because I can't edit it in the right hand pane by clicking on the Object section because it isn't there and if I click on the menu on the bottom to try to leave Object Mode, it doesn't give me any other choices and pressing tab does nothing. If I press n I get shown grease pencil stuff rather than the usual object properties when something is selected.

Hopefully someone knows what's going on here.

Some other info:

  • There's a half made anvil on the last layer that I can select/edit just fine
  • The main (finished) anvil has a subsurf modifier on it with a very high tri/quad count
  • The main anvil has a mirror modifier on it
  • I know the screenshot shows I have two layers selected, I've deselected the second layer and it does nothing
  • I'm on Windows 7 with an Intel CPU and no GPU :(

If there's anything else I can add to help anyone figure out what's going on, please let me know.

$\endgroup$

marked as duplicate by cegaton, David Apr 21 '18 at 1:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ "Intel CPU and no GPU" I doubt that, you probably have an integrated Intel car which are known to cause problems and have poor performance, and is also possibly responsible for crashes. Try updating your graphics drivers $\endgroup$ – Duarte Farrajota Ramos Apr 20 '18 at 0:15
  • $\begingroup$ I just said no GPU because I'm not using a GPU for rendering because I don't have a separate GPU since I'm working on a super cheap laptop atm. :/ $\endgroup$ – gucciferXCIV Apr 22 '18 at 22:21
2
$\begingroup$

Reduce the number of subdivisions in your anvil subsurf modifier.

It has 6 subdivision iterations giving it an impossibly high poly count. Not only is that unnecessary, it will give poor performance, consume large amount of RAM, and as you experienced already, possibly cause crashes on lower end machines.

$\endgroup$
  • 1
    $\begingroup$ Almost Three million faces for such a simple object is too much. Read this related link: blender.stackexchange.com/questions/15654/… $\endgroup$ – cegaton Apr 20 '18 at 15:36
  • $\begingroup$ I know it's waaaay too many haha, I was just messing around with Blender because I'm new to it. But I'll try to see what I can do. Me being unable to select the object is making lowering the subdivisions a problem. Anyways I've updated my drivers. I'll see if anything has changed. Thanks! $\endgroup$ – gucciferXCIV Apr 22 '18 at 22:17
  • $\begingroup$ @cegaton Just kidding. I live for high poly anvils. They're my life, bro. $\endgroup$ – gucciferXCIV Apr 22 '18 at 22:24
2
$\begingroup$

EXCEPTION_ACCESS_VIOLATION: Is most probably caused by your memory. As Duarte said: 6 sub-divs is a lot.

Orange Outline: means the object is selected, but not the active object (yellow outline). I get this, too, when opening your .blend and pressing 'a'. What fixed it for me is deselecting the empty layer and just clicking on the anvil.

'n' for Grease Pencil: I was able to replicate the problem: Again, you're not seeing the transform section because you have no ACTIVE object (yellow outline).

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.