1
$\begingroup$

I have an object with 3 separate layers/meshes. I need it to be only 1 layer to import and attached various scripts in unity. I have brought it into blender and joined the separate meshes so now only one mesh and also one UV layer. But when I export it out again as a.obj file and then import the .obj file to unity it separate it again into 3 separate layers. am I exporting it incorrectly?

$\endgroup$

1 Answer 1

1
$\begingroup$

I'm sorry, I'm not allowed to comment questions, so I have to answer: I was not able to replicate the problem with different export settings, so I'm guessing it's how you join the meshes. Did you combine them by pressing 'ctrl+j'? What are your export settings?

$\endgroup$
4
  • $\begingroup$ Hi Yes, I used ctrl + j to combine the meshes and I can see there is now one layer instead of three previously. The export settings I use are export > wavefront (.obj) and then ticked are ‘apply modifiers’, ‘include edges’, ‘write normals’, ‘include UVs’, ‘write materials’ and ‘objects as OBJ objects’. I exported as a .fbx file also, but the same problem .i.e. when I import into unity the 3 original meshes are on 3 separate layers. $\endgroup$
    – patrick
    Apr 20, 2018 at 8:53
  • $\begingroup$ Could you provide the .blend and/or .fbx? I'm guessing your problem is on the Unity-side of things and would like to test it. $\endgroup$
    – Lucas
    Apr 20, 2018 at 10:15
  • $\begingroup$ sure, do you have an email I can get u on? Yes, I think the problem is Maybe with the unity import. thanks $\endgroup$
    – patrick
    Apr 20, 2018 at 11:15
  • $\begingroup$ Hi, I used the Decimater object modifer at 0.1 and this has solved the problem. Many thanks for your help. P $\endgroup$
    – patrick
    Apr 20, 2018 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .