0
$\begingroup$

I am trying to get my textures and materials to show up in the 3d viewport while playing the animation of my scene. The textures and materials are showing in my 3d viewport. However, when i play the animation the objects do not move until i stop the animation.

Right now i have my method to display objects in the 3d view set to rendered. If i have it set to anything else, the textures and materials go away and i only see the blank objects, but they will move with the animation.

How can i get the objects to properly animate in the 3d viewport with textures and materials applied?


Clarification:

I press alt+A to run the animation. The animation plays, but none of my objects move like they are supposed to. Then i press alt+A and the objects jump to the location they are supposed to be at the frame where the animation stopped. I want the animations to move like they are supposed to while the animation is playing. I can stop through the animation using the timeline by pressing left or right arrow and the objects move. But i want this to work while playing the animation.

Thanks

$\endgroup$
  • $\begingroup$ @MrZak Added clarification. $\endgroup$ – prolink007 Apr 19 '18 at 15:51
  • 1
    $\begingroup$ Do you mean animated texures (as in an image sequence or a video file used as texture?) $\endgroup$ – cegaton Apr 19 '18 at 15:54
  • $\begingroup$ @cegaton I have a plane that moves from left to right that has a material and texture applied to the surface. $\endgroup$ – prolink007 Apr 19 '18 at 16:40
1
$\begingroup$

When using the viewport in render view mode, sluggish animation and freezing are not uncommon when you try to play your animation. Try setting the viewport render mode to "material" or "textured" and you should be able to play animations smoothly with your textures/materials visible and animated.

This has one caveat however, the Blender Internal render engine does not support procedural texure in material view mode, and will display the object incorrectly.

$\endgroup$
  • $\begingroup$ I have already tried that, i mentioned it in the question. $\endgroup$ – prolink007 Apr 19 '18 at 18:45
  • $\begingroup$ Ah right I see that now. My mistake. $\endgroup$ – Tavi Kohn Apr 19 '18 at 19:23
  • $\begingroup$ no problem, easy mistake $\endgroup$ – prolink007 Apr 19 '18 at 19:33
  • $\begingroup$ I've done some searching. It appears that Blender Internal does not support procedural textures in the viewport. If I create a material and give it a texture however, it shows up and animates correctly in material view. As soon as I mix in a procedural texure however, the material breaks in the viewport. $\endgroup$ – Tavi Kohn Apr 19 '18 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.