1
$\begingroup$

I followed a tutorial on how to make a good paint texture (found here: https://www.youtube.com/watch?v=jlfBvt0O6Dk).

The texture came out nice, but when i go to add a glass texture for the windows it always looks as if it has Voronoi applied to it.

I note that there is a distinct possibility that it has nothing to do with Voronoi, but it is the best way i can describe the way the glass looks.

The final render (showing how the glass is keeping Voronoi?) enter image description here

The nodes used to create the paint texture (This shouldn't have anything to do with the glass, but i'll keep it here just in case)

enter image description here The nodes used to create glass texture enter image description here

https://imgur.com/a/6sL8T

The desired output would look something like this:GlassRemoved

(this was done by removing the glass and thus isn't really adequate as a solution)

Here is a copy of the Blender file: https://www.dropbox.com/s/toms123eho2w589/2017fordfocus.zip?dl=0

$\endgroup$
  • 1
    $\begingroup$ That doesn’t look like Voronoi to me - more like faces. Check that you don’t have overlapping geometry, odd normals or extreme camera clipping values. $\endgroup$ – Rich Sedman Apr 19 '18 at 10:01
  • 1
    $\begingroup$ The windshield probably has bad geometry and the car paint parts also seem to display the same shading error but it's less visible. Does the glass have thickness or is it just one surface? Being physically accurate, Cycles glass always needs a thickness (an enter surface and exit surface) otherwise the entire car is filled with glass that refracts light. $\endgroup$ – kheetor Apr 19 '18 at 11:28
  • $\begingroup$ The model was downloaded from Google sketchup's warehouse as a .dae file which was then imported into blender. When i go to the settings to follow link 1 there is no option called "Clear Custom Split Normals Data." I'll upload the blender file if anyone would please take a look at it $\endgroup$ – zorua98741 Apr 20 '18 at 3:48
2
$\begingroup$

The model is a mess. When you download models created by other people you are always prone to inherit a lot of buggy geometry and bad modelling habits of the creator, plus those created by the translation into different formats.

The particular model is plagued with duplicated geometry, hence the z-fighting. All of those dark triangles that you see are not only on the windshield but in every surface, are caused by overlapping vertices

You need to do "remove doubles".

The normals are all messed up (in edit mode select all of the vertices and make them consistent (Ctrl+N).

On top of that, whenever you are dealing with glass you need it to have some thickness (see this link: https://blender.stackexchange.com/a/69616/1853)

The glass shader you are using makes no sense. See this link for a proper shader: How to illuminate the darkness inside glass objects in Cycles?.

The scale for the object is also wrong.

There is probably more, but that you will have to figure out on your own.

If you are doing experiments with textures, first make sure that the model you are going to use is decently crafted so that you can focus on the textures.

$\endgroup$
  • $\begingroup$ thank you very much Cegaton, selecting all vertices and pressing CTRL + N fixed the issue with the glass (in case someone else comes at a later date: select part of model > TAB (edit mode) > A (select all vertices) > CTRL + N (fix overlap(?)) > TAB (exit edit mode) ) $\endgroup$ – zorua98741 Apr 20 '18 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.