0
$\begingroup$

I know many many people have asked this before, but i really can't understand what is wrong...
I've tried everything: raised passes up to 3k, added denoising, indirect clamping, multi sample resolution, raised and lowered light bounces, doubled the resolution in order to scale it down later, removed all light sources except the external, the light path node for the glass material then removed glass from windows...

Nothing worked, i can't get a nice image...

So, i'm asking you to have a look at my file (a corrected copy can be found in the answer)...
The HDR image can be found here.
All other textures should be generated with noises

Result with 2000 Passes after taking advantage of light portals Result after taking advantage of light portals

$\endgroup$
  • $\begingroup$ please don't services with temporary links (like wetransfer) to share your files, once the link expires no one will be able to learn from your file. Please use blend-exchange.giantcowfilms.com to share your file on question in this site. $\endgroup$ – user1853 Apr 19 '18 at 15:51
2
$\begingroup$

Since this is an interior scene with windows being the primary light source, you will want to use a feature called Light Portals.

Basically, you add an area lamp into each window, align it so that the plane of the lamp is in line with the plane of the window, scale the lamp up (using the size value in the lamp settings) to be the same size as the window, and then check the Portal option that is also found in the lamp settings.

These portals help Cycles figure out where the light is coming from, and can greatly reduce noise.

Here's a good video that goes over setting them up and how they work: https://www.youtube.com/watch?v=1LjLyTBbl6s.

EDIT: Here's an actual comparison of your scene. I added a portal at each window/door/skylight, and used the exact same settings as you had. The only difference was that I changed the dimension scaling from 200% to 50% and the samples from 2000 to 50, just so I could do this quickly.

Here is with no Portals and 50 samples. It took 38s to render on my GPU.

enter image description here

Now here is the result with a portal at each light source (even the ones outside the camera view). It took only 4 seconds longer at just over 42 seconds.

enter image description here

And I think those results speak for themselves... :)

Here's the file too if you want to look at what I did. You will have to relocate the HDRi though, as I had to set it to a different path on my system.

EDIT #2 I also noticed that you have a large number of light bounces. Since the portals really brighten up the image as well as reduce the noise, you can lower the bounces back down, and it will make your image even brighter, as well as render a bit faster. A max of 8 bounces and min of 3 gave this result and shaved just over a second off the time as well.

enter image description here

Do keep in mind that this is an interior scene, and the nature of interior scenes is that there are a lot of light bounces, especially when using multiple light sources. Keeping the bounces low will help with noise, brightness and render times, although for a good final render a few thousand samples will still be necessary.

$\endgroup$
  • $\begingroup$ Also for your glass shader use this setup: blender.stackexchange.com/questions/47851/…. And disable ambient occlusion. In cycles you don't really need it. $\endgroup$ – user1853 Apr 19 '18 at 2:04
  • $\begingroup$ Great points to add. I would definitely suggest going through all the different materials and settings now that the main source of noise has been dealt with. Up until this point I'm guessing the small changes weren't even noticeable due to the overwhelming amount of noise. I gave this scene a quick test render at 500 samples, and it was still fairly noisy, but with optimizations I think it is feasible to get a relatively noise free result at around 500-1000 samples (but for a final render I would still do a few thousand). $\endgroup$ – Brenticus Apr 19 '18 at 4:27
  • $\begingroup$ Ok, i'll give this a render at 2k, and provide feedback! $\endgroup$ – L.Trabacchin Apr 19 '18 at 8:06
  • $\begingroup$ @Brenticus i've tried to render the scene with a material that i've called lightstudy or something light that, but i tought it was noisy because of not so much renderpasses $\endgroup$ – L.Trabacchin Apr 19 '18 at 8:14
  • $\begingroup$ @cegaton damn ambient occlusion was causing spikes of fireflies where two surfaces met... I think denoise is giving me some other problems... $\endgroup$ – L.Trabacchin Apr 19 '18 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.