0
$\begingroup$

Im trying to extrude points outwards like in this video at 24:50 https://www.youtube.com/watch?v=YbsYDOiph7U

This is what is happening.enter image description here

$\endgroup$
1
$\begingroup$

It is most likely an issue with the normals of your faces (the way that blender thinks the faces are pointing). You also appear to have some duplicate vertices that are throwing things off.

I would do these steps (starting from before you extruded the faces shown in the image):

-Select everything with A

-Press W and select Remove Doubles

-With everything still selected press Ctrl+N which will force blender to recalculate the normals of the faces.

-Select the faces you need again and extrude with E and it should work.

Duplicated vertices are often caused when you extrude a face and then cancel the extrusion with right click. Despite it appearing that the extrusion has been cancelled, extra vertices will have been created that are in the exact same location as other vertices. This can get Blender confused about which way is out for some faces.

$\endgroup$
  • $\begingroup$ They still are extruding in the wrong directions $\endgroup$ – Sam Davenport Apr 18 '18 at 18:58
  • $\begingroup$ Try switching the menu at the bottom of the 3d view from Global to Normal, then after pressing E, press Z a few times to cycle through all the axes you can extrude along. After pressing Z 3 times it should be extruding along the proper axes. If not, can you upload your file and include it in your post to I can take a look? $\endgroup$ – Brenticus Apr 18 '18 at 19:02
0
$\begingroup$

You need to use "Extrude Individual" instead of "Extrude Region" - E - shortcut.

EDIT: NO, I was wrong. In your case you need to use "Extrude - Region (Vertex normals) from drop down menu "Extrude"

enter image description here

$\endgroup$
  • $\begingroup$ Using regular extrude as done in the video should work though. I'm curious as to why it doesn't for Sam. But you are right, I believe this option would work too. The keyboard shortcut is Alt-E, since doing it via the toolbar is usually pretty awkward. $\endgroup$ – Brenticus Apr 18 '18 at 19:47
  • $\begingroup$ @Brenticus Regural extrude doesn't work me too. $\endgroup$ – Shubol3D Apr 18 '18 at 20:54
  • $\begingroup$ That is very interesting. I tested it and it worked fine for me (with individual origins as the pivot point as in the video). Did you use individual origins? $\endgroup$ – Brenticus Apr 18 '18 at 23:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.