So I appended a group of objects to my level in BGE, but every time I reopen it (the level) the appended groups go back to the location at which they are saved in their own individual files. How do I get the groups of objects to remain where I put them in the level? Thanks.

  • $\begingroup$ Are these 'groups' animated at all? Not sure about groups but Keyframes will place objects in their keyframed locations when appended. The answer to that is to adjust their positioning in the Graph Editor. Can drop more details here as an answer if needed. $\endgroup$
    – Edgel3D
    Apr 18, 2018 at 19:42
  • $\begingroup$ Added to the above - this might be useful - 2nd method blender.stackexchange.com/questions/99821/… $\endgroup$
    – Edgel3D
    Apr 18, 2018 at 19:59
  • $\begingroup$ That second method may work. Can't try it at the moment. My group has an animated armature parented to a physics cube. $\endgroup$
    – Silas
    Apr 18, 2018 at 21:28
  • $\begingroup$ Hey, sorry for coming back so long after you replied. Could you add more details like you offered? I have not used the graph editor before, so that would be greatly appreciated. :) $\endgroup$
    – Silas
    Apr 30, 2018 at 22:19

1 Answer 1


Not sure you'll need to muck around with the Graph Editor - Try this first...

Select the main armature or whatever it's parented to.

Press SH-S --> Cursor to selected.

SH-A and add an Empty. (It will appear at the the same origin/pivot point as the armature or parent)

Parent the armature (or parent) to the Empty, choose "Object (keep transform)"

Drag the empty around and the model should follow it. Place it somewhere. Run the animation.

It should do it's thing but now from it's new location.

  • $\begingroup$ Well, my armature is parented to a cube. When I parent the cube to the empty, go to a different scene and then come back to the first scene, it appears in its original position. Then I tried to parent the armature to the empty as well, I tried the same thing and the armature stayed but the cube did not... $\endgroup$
    – Silas
    May 2, 2018 at 15:14
  • $\begingroup$ Wait... I saw that my cube had an action which must have happened because I had automatic keyframe insertion on. I deleted it and now it works, but I'm confused. How did it work on the armature that had actions and not the cube that had an action? Oh well. At least it works. Thanks! :) $\endgroup$
    – Silas
    May 2, 2018 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .