I'm using Pop!_OS 17.10 (based on Ubuntu 17.10) on a Dell XPS 15 9560 and Blender 2.79b. CUDA is installed, the Nvidia GPU (GeForce GTX 1050) activated and Blender is recognising both:

enter image description here

But when I hit render, it's rendering on the CPU:

enter image description here

This is my second Pop!_OS installation because I messed up the previous one. But before, Blender was rendering on the GPU as expected. Am I missing something here? How can I make this work again?

up vote 3 down vote accepted

on your render settings, make sure you have the rendering device set to GPU and not CPU, selecting CUDA on user preferences only enables the option to render with a GPU but you still need to change it on the render settings enter image description here

  • Wow, now I feel really stupid :) Thanks for pointing that out! – wout Apr 18 at 17:52
  • haha that happens some times, I get so stressed that I don't realize it's a 1 click solution xD, I'm glad I could help – Zophiekat Apr 18 at 19:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.