4
$\begingroup$

As part of a larger project, I created a simple human mesh in MakeHuman, enabled MoCap with it in MakeHuman, and imported it inro blender as an FBX file.

When I 'Load and Retarget' the .bvh file I want to use, the model/rig dosn't go into a t-pose as it's supposed to, it is bent at the hips. This totally screws up the animation, as it looks like the figure is always leaning over. This happens with all the MoCap files I try.

I tried going into pose mode and bending the hips back into a normal position, but because the hips are constrained, I can't find a way to do that. I've re-made and exported the .fbx file, and re-downloaded the MoCap files with the assumption that it was just the files that were corrupted, but the problem persists.

Here's a screenshot: enter image description here

The guide I've been using to do all this is this video by Remmington Graphics.

The MoCap files I'm using come from this site.

What is causing this issue and what can I do to fix it?

Thanks in advance!

Here is the .blend with the extra files packed into it:

EDIT: Here is the MoCap file, a FBX file and a DAE file.

https://drive.google.com/file/d/12RfzXPWZ-7SgoaRTD9LNmtk_bEmFIk0q/view?usp=sharing

https://drive.google.com/file/d/1MD2nwFtcIBvpLKuFYxUMyYAmB6oMREla/view?usp=sharing

https://drive.google.com/file/d/1konpJ3EGeyZH47Zf7OtbTI41O_fSxfqP/view?usp=sharing

$\endgroup$
  • 1
    $\begingroup$ Better if you post the bvh and the model separately, without any Blender conversion. So we can check all the chain from the beginning $\endgroup$ – Kabu Apr 18 '18 at 7:53
  • $\begingroup$ Ok, I did that. $\endgroup$ – Dr. Farquaad Apr 19 '18 at 2:24
3
+100
$\begingroup$

The video author is using Blender 2.77a, you are using 2.79. This is important since Blender got a few tweaks on importing Collada files.

I am using 2.79b and tried to replicate your problem. I don't get the same problem but I do get issues when importing Collada if I do it the way its done in the video. I was able to solve it with this setting:

settings

This fixed my issues, I hope it fixes yours.

Steps taken:

  • Exported character from MakeHuman as Collada file with Mocap skeleton
  • Imported Collada file in Blender with the "Auto Connect" setting
  • Selected the skeleton. Made sure its in Object Mode
  • In the MakeWalk v1.1.0 panel, pressed Load and Retarget and selected the Mocap file
  • Played the animation

steps taken bvh

It is also worth noting that I downloaded the "Daz friendly" version of the Mocap Files.

$\endgroup$
  • $\begingroup$ Ok, I did that, but now when i go to 'Load and Retarget' it gives me a traceback error. What next? $\endgroup$ – Dr. Farquaad Apr 18 '18 at 22:03
  • 1
    $\begingroup$ I got that message as well. When you select the rig, it sometimes goes into Edit Mode. Make sure that the rig is in Object Mode. $\endgroup$ – Timo Apr 19 '18 at 8:42
0
$\begingroup$

The MH model skeleton from the dae model:

enter image description here

The bvh skeleton:

enter image description here

See the position are different. For starters, they have to be the same. Trying to use the MH load and retarget yields:

enter image description here

It appears there's an incorrect model binding, and a broken starting position... Normally, you may want to retarget the BVH bone structure to the MH one... if this yields correct results you're ok then... If not, then you have to go for the manual bindings... align the bones to the model, fix the starting position, parent the model to the armature (fixing weights if necessary), test the animation. (By the way, in your original blend the model seemed to walk and jump a ledge, while this animation show a hand-walking exercise. Sure they are the same?)

$\endgroup$
  • $\begingroup$ Oh it might be that I selected the wrong file oh well $\endgroup$ – Dr. Farquaad Apr 19 '18 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.