2
$\begingroup$

When I grab a parent with children assigned to it, only the parent moves. Also When I select multiple object and try to move them, only the active object (the yellow one) moves.
I must have accidentally toggled something. So, what shortcut did I accidentally hit?

$\endgroup$
4
  • $\begingroup$ Did it work before? Could it be that you move the child instead of the parent? $\endgroup$
    – stacker
    May 23, 2014 at 14:49
  • $\begingroup$ It worked before. And I'm sure i had the parent selected and only moved it. And (in the other case) when I had multiple object selected, only one would move. $\endgroup$
    – Ryan Lutz
    May 23, 2014 at 14:52
  • $\begingroup$ I have found that when I select all the objects in the scene and try to move them, only the object highest in the hierarchy moves. $\endgroup$
    – Ryan Lutz
    May 23, 2014 at 14:56
  • 1
    $\begingroup$ @Ryan Lutz: About the term fot the yellow object: it is called the 'active' object. The orange ones are the selected objects. The active object does not necessarily have to be a selected one though. For example if you select an object and then press [Ctrl+I] to invert the selection, the previously selected object is still the active one although it is no longer selected. $\endgroup$
    – maddin45
    May 23, 2014 at 18:10

3 Answers 3

6
$\begingroup$

If you link in an object from an external file you can't move it by default, even if you parent it to a local object. In this case the selected object should be highlighted in blue unless you alter the theme colours. You can make a proxy or make a local copy to move it, or move it in the original file.

A linked object will have a small file icon next to it in the outliner. This icon will also be seen in a few other places like the object properties. All values will also be greyed out.

enter image description here

The only other thing that should prevent a child moving with it's parent is a constraint.

enter image description here

Similar constraints are available for rotation and scale. Clicking the X in the corner will delete them or you can turn off the limit that is bothering you.

Something that can stop an object being moved by itself (but should still move with a parent) is locking the transform channels. Available in both the object properties and the properties sidebar, clicking these "padlocks" will prevent the related transform channel from being altered in the 3DView. You can actually alter the values displayed to move objects while they are locked, just not with g,s,r in the viewport.

enter image description here

Simply click the locks to unlock them.

The values may also have drivers attached to them. When a value is being driven it is highlighted in purple.

enter image description here

Right click on the value and select Delete Drivers.

$\endgroup$
1
$\begingroup$

This can also happen if you inadvertently turned on any kind of physics modifiers. (This one took me a good hour to figure out!) Go to the physics tab and make sure that there is nothing present).

$\endgroup$
1
  • $\begingroup$ Actually, merely freeing any physics bakes should do it - (Don't forget to re-bake after moving you stuff!) $\endgroup$
    – Brad
    Mar 17, 2015 at 14:06
1
$\begingroup$

This was driving me insane as well and it was a super simple fix. I had my proportional editing button on(o) As soon as I turned it off everything moved correctly.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .