2
$\begingroup$

I have been doing some work on a file in the default view, doing all of my work there, including some compositing. However, after I decided to do the modeling in the default view, and make the compositing view used for compositing, I went to go adjust my compositor setup, but all my compositor nodes are gone, and I can't add any - all the options are grayed out. It appears the composition setup is still being applied to the render, but I can't find the setup. What happened? Where are my compositor nodes?

$\endgroup$
2

1 Answer 1

2
$\begingroup$

There is a second scene called testlight, which has Use nodes disabled.

Enable nodes in testlight, then the nodes will appear and work fine in the main scene.


I'm not sure why this happens. I think it might be a bug, you might want to try reporting it (particularly if you can figure out how it got this way in the first place).

Re-disabling use nodes in testlight doesn't seem to disable nodes in the other scene again.

$\endgroup$
1
  • $\begingroup$ I added that scene when lighting was having issues. I never did compositing in there. Looks like switching it on and off got Blender to realize there were nodes again. Thanks! $\endgroup$ May 23, 2014 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.