8
$\begingroup$

I created several objects, applied its material with a texture. When I render the scene it all render nicely except one. It renders black both in cycles and BI. I have tried everything. I don't know whether I have missed something or not But I'm not getting the result properly. What is the solution to this 'rendering black' problem?

$\endgroup$
  • 1
    $\begingroup$ Could you add your .blend by using a service like pasteall.org/blend $\endgroup$ – stacker May 22 '14 at 10:46
  • $\begingroup$ @stacker :Here it is pasteall.org/blend/29373 $\endgroup$ – Flare'D May 22 '14 at 10:52
  • $\begingroup$ What do you think @stacker ? Do you have any idea on this? $\endgroup$ – Flare'D May 22 '14 at 10:59
  • $\begingroup$ @Flare'D you didn't include the textures in the blend file. DO this and Upload again. File -> External Data -> Pack into .blend $\endgroup$ – Vader May 22 '14 at 11:04
  • $\begingroup$ The object you uploaded renders fine for me. But you have to make sure that 'Use Nodes' is checked when rendering in Cycles and nodes are unchecked when you switch to Blender Internal renderer. Otherwise you will get a black material in Cycles and nothing in Blender Internal. $\endgroup$ – maddin45 May 22 '14 at 11:07
4
$\begingroup$

Your UV coordinates are set to the wrong set of coordinates for rendering. Click on the camea icon right of 'UVMap_final' to activate it as the UV map for rendering.
enter image description here
The Viewport and the UV Editor always show the set of UV coordinates selected (the one highlighted blue), but this has not to be the set used for rendering.

$\endgroup$
  • $\begingroup$ What if you don't have a UVMap Final, just a UV Tex, and its camera is on? $\endgroup$ – MicroMachine Nov 20 '15 at 0:33
  • $\begingroup$ That UV map should be the active one. 'UVMap' is the default name of the first UV map. When adding additional UV maps they will be called 'UVMap.001' and so on. You can name the UV maps as you wish. You can change the name of a UV map by [Ctrl]+[LMB] clicking on the name. $\endgroup$ – maddin45 Nov 21 '15 at 10:43
7
$\begingroup$

You can fix it by adding an attribute node to assign the UV map you intent to use:

I made minor changes in the node editor: enter image description here

$\endgroup$
3
$\begingroup$

Here what I found for my ´black render´ issue: disable Áuto Smooth´

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Actually this is another probable cause for a black render. I do not know why someone downvoted it. On a very simple material, even without a texture, it can render black. But probably this issue needs to be looked in deep. It also can be because fliped normals. $\endgroup$ – Rafael Nov 17 '17 at 23:13
  • $\begingroup$ That worked for me still in 2019 and Blender 2.80. Needed to import a very complex and unoptimized model from vector works as obj and re-texture it incl. new uv. But certain areas always rendered black although correctly textured. After tunring off autosmooth they rendered correctly. $\endgroup$ – Carsten H Aug 21 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.