1
$\begingroup$

Thanks in advance to this wonderful community that has helped me a ton on the way. With that preface, here is my problem. I am trying to get the most basic of simulation to work correctly. The top cube is a soft body and the bottom cube is a collision object. I can't get these two objects to interact at all. I have tried adding a collision modifier to the soft body cube (in addition to the soft body modifier). The soft body cube also doesn't have the soft body goal (as I am trying to get a bouncing effect where the cube bounces off of the plane).

The normals of both objects are facing the right direction. I have also played a ton with the inner and outer settings of the collision object to no avail. What're your guys' thoughts?

Below is the beginning of the animation and the end of the animation (where the cube just falls through the surface of the collision object).

Also do you have to bake it before it will interact correctly? I already tried that as well and nothing happened.

I also thought it might have to do with the fact that I had no vertex groups specified on my soft body object. I did, however try subdividing the cube a bunch and still nothing was happening.

enter image description here

enter image description here

$\endgroup$
1
$\begingroup$

You need to add the Collision physics to the object that yhe soft body should be colliding with, not to the soft body itself. Also, check your normals to ensure they’re pointing ‘outwards’ (otherwise the collision won’t work).

Another issue can be where the Soft Body/Cloth collision ‘Inner’ setting (on the non-soft body mesh) is set too large - it ahould never exceed half the thickness of the mesh or it can have undesired consequences (drawing the soft body through from the ppposite side).

Also, fast moving collisions can potentially get through the surface before they are detected. To address this, increase the Min steps (and Max if you need to increase Min even higher) in the Soft Body Solver settings.


After reviewing the Blend file I noticed that the collision object and the soft body are actually on different layers. For the collision to be active (in fact, for any physics effects) the meshes must share the same layer. To move objects to a different layer you should select them, hit M and click on the desired 'target' layer on the popup panel, holding Shift to select multiple layers if desired. Note that moving layers doesn't necessarily invalidate the soft body cache but this can be triggered by simply selecting the Soft Body object and going into and out of Edit mode (TabTab).

animated working

$\endgroup$
  • $\begingroup$ I already tried all of those things and none of them worked unfortunately $\endgroup$ – Tyler Dahl Apr 10 '18 at 17:28
  • $\begingroup$ Yeah I already did that as well:( $\endgroup$ – Tyler Dahl Apr 10 '18 at 17:32
  • $\begingroup$ Upload your blend file to blend exchange and add a link in to your question and I can take a look later. $\endgroup$ – Rich Sedman Apr 10 '18 at 17:34
  • $\begingroup$ Here it is: <img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=4762" /> $\endgroup$ – Tyler Dahl Apr 10 '18 at 17:34
  • 1
    $\begingroup$ Spotted the problem - the soft body was on a different layer to the 'floor'. $\endgroup$ – Rich Sedman Apr 10 '18 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.