1
$\begingroup$

So I finally finished my 1st animation in blender and wanted to check it on UE4. I tried to export it but when I click export, doesn't technically crash but it stops responding and into "thinking" mode. It works when I disable animations but I need them. I'm mostly a beginner in this stuff so any help will be appreciated.

Edit: Deactivated "All Actions". It works now

I'm using blender version 2.79b on Windows 10.

$\endgroup$
2
$\begingroup$

Tips to avoid this:

  • Activate Selected Objects (not whole scene)
  • Activate only "Deform Bones" under Armature tab(so rig won't corrupt the FBX if many constraints, or loopback bones that might make it bug - will also export in a clean way, etc)
  • Disactivate "All Actions" from Animation tab (so that rig will export only it's aniamtion clips, not the whole scene animation
  • Make sure that SDS is at a reasonable level of Render Settings (1 or 2 max), SDS at 3 or 4 will take a long time to "Apply Modifiers" to the mesh - specially if it's a whole scene. You can optionally turn this "Apply Render setting modifiers" off under Geometries tab

Then export and the software won't have to think so hard or ultimately crash.

$\endgroup$
  • 1
    $\begingroup$ tnx for your help $\endgroup$ – Apoorva Aditya Apr 11 '18 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.