0
$\begingroup$

I am new to Blender and 3D modeling in general. After downloading the newest version of Blender, I found the UI to be incredibly unresponsive and laggy. I looked up solutions online, such as changing the way the window is rendered or adding Blender.exe to the Nvidia 3D control panel and using all of the settings available. The only thing I could not do is run Blender with integrated graphics since I have no integrated graphics card in my desktop, so the option does not appear.

I have: GTX 1080 Intel i7-4790K CPU 4.00GHz 16 GB RAM Windows 10 2 500GB SSDs

I even checked a post on here with a similar problem and computer specs, but none of the solutions worked, some even made things worse. Does anyone have any other suggestions?

$\endgroup$
  • $\begingroup$ Welcome to Blender SE. Check your Task Manager, see if you have any CPU-hungry operations going in in the background. I found that removing GeForce Experience also increased performance. The fact that you have no Integrated graphics card might be a problem: unlikely, but do report this issue with the folks at Blender directly. $\endgroup$ – OroNZ Apr 10 '18 at 8:16
  • $\begingroup$ Thank you for your response OroNZ. I checked to see what my CPU usage was while running Blender, and it doesn't even go above 30%. It seems to cap out at 6 GB Memory usage though, despite having 16 GB total $\endgroup$ – Drake Apr 10 '18 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.