0
$\begingroup$

I was following ben u's tutorial on Basic Volume Shading.
https://www.youtube.com/watch?v=9Ybk0qNFhqw

I was doing OK with "Volume Scatter", but as soon as I put in the "Add Node" (3 min 46 seconds in tutorial) and then tried to add "Volume Absorption" shader, the cube turned black.

3 min 46 seconds into tutorial

I tried this https://blenderartists.org/forum/attachment.php?attachmentid=402469&d=1443634665 but, got the same result.

There must be something very basic that I'm missing but, I don't have a clue what it is.

Would greatly appreciate your help. Thanks.

$\endgroup$
  • 1
    $\begingroup$ "There must be something very basic that I'm missing" You are using a Color Mix node to mix two shaders, instead of a Shader Add $\endgroup$ – Duarte Farrajota Ramos Apr 9 '18 at 0:45
3
$\begingroup$

Wrong Add node

The Math (Add) node you are using works with grayscale values (on the left in the image below).

You would like instead to Add a shading to another shading: you must use the Add Shader node you can find in the Shader nodes group (on the right in the following image).

enter image description here

The color of the input/output socket is always a guide for the correct connection.

$\endgroup$
  • $\begingroup$ That did it! Even though it was that elemental, I probably would never of figured it out. Much Obliged! $\endgroup$ – sweathog55 Apr 8 '18 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.