1
$\begingroup$

I'm trying to rig and animate a character for use in an OpenGL-based program. I found a simple character model on TF3DM and rigged him by following the excellent character rigging tutorial from BlenderGuru. I can export the animation to the COLLADA format and load that file into my software. Most of the animation comes through, except for a few small details like the bending of his toes. His toes seem to be stuck in their initial state, with his left foot flat and his right foot bent.

Here his right foot is bent properly while his left foot remains flat: Right foot correctly bent, left foot flat

Here, his right foot is still bent. The leg has moved properly, but the foot hasn't bent like it should have: enter image description here

This behavior happens in more than one program, including when I export as COLLADA then import it back into Blender. With a simpler model (an elongated cube with only two bones), it exports just fine.

UPDATE: Here's a screenshot of the model when I export from Blender, open a new scene, and import the model. Some of the bones are tiny. Not sure why: Tiny bones

Does this sound like a problem with the COLLADA exporter? Or is it more likely to be a problem with my rig? (Would it be helpful to upload my .blend/.dae file somehow?)

$\endgroup$
1
$\begingroup$

I figured out the first problem. Based on suggestions from this BlenderArtists thread and this extremely helpful Wildfire Games article, I figured out that I needed to bake the animation with the 'visual keying' box selected. To access this, I selected the skeleton, then navigated to Bake Action (Pose > Animation > Bake Action...) and checked the 'Visual Keying', 'Clear Constraints', and 'Clear Parents' boxes. These options also take care of rigs that include inverse kinematics.

As the Wildfire Games article suggested, try to avoid unchecking 'inherit rotation' on any bone, as it will not export properly.

(As for the tiny bones problem, I have no idea what's going on there)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.