1
$\begingroup$

I have this mesh:

Tomato

I Bisect it, select one of the parts, and Separate>By Selection.

My problem is that because the vertices are not shared, there is a visible seam between the two parts. Is it possible to be seamless?

Bisected Tomato

The whole mesh is smoothly shaded, but I've tried setting the bisection vertices and edges to flat shading (in order to have the same normals), as well as marking the edge as a seam and unwrapping, but it didn;t improve anything.

$\endgroup$
4
$\begingroup$

This is the result of mismatch in normals orientation.

Smooth shading averages normals of the vertices which compose the faces. On the surface where each face is connected to the neighbour face this will work as they share vertices and hence normals have the same orientation.
On the other hand when surface ends the normal of the vertex which is on the boundary loop won't be the same as above because it won't have neighbours to have the same average result of the normal vector orientation. Here's an example of a sphere with a segment cut out and left as part of the same object:

enter image description here

Blue lines show vertices normals' orientation. They are doubled and mismatch a bit where double vertices meet. And shading has visible artifacts there.

Often you will be advised to remove doubles to workaround that. If you need these as different meshes the easiest way is to split meshes into different objects in order to use modifier to transfer normals from one object to another, this is Data Transfer modifier.

After seperating segment into another object enter Edit mode, select boundary loop edge (Ctrl + E > Select Boundary Loop) and add it to a vertex group.

enter image description here

So that if you enter Weight Paint mode you will see red in the corners (weights of 1):

enter image description here

Do the same for the sphere itself:

enter image description here

Then add Data Transfer modifiers for both objects. Choose Sphere as source object for the segment and Sphere-segment for the Sphere object in its settings. Enable Face Corner Data checkbox to tell modifier what to transfer. Choose Custom Normals below. In the Vertex Group field choose groups created above. Set Mix Mode for the modifier on the sphere to Add, leave default Replace for the one on the segment. Enable AutoSmooth in the Object Data tab to make both modifiers work.

enter image description here

Now the cut out segment won't be seen as separate mesh.

enter image description here

$\endgroup$
1
$\begingroup$

In some ways smoothing of a surface works like the subsurface modifier, or you can think like it works like wise. I would suggest, you add some extra edges at the cutted surface. With that extra edge you are helping the smoothing by giving more guidlines where to smooth. Additionally you can mark an edge as sharp by selecting it and hit Shift + E, enter value by moving the mouse (or add the value into the properties panel). Careful, sometimes sharpening gives unexpected results.Added another Edge at the border and made the Edge sharp (Shift + E) Added another Edge at the border and made the Edge sharp (Shift + E)

Side by Side Comparison, left with extra edges and sharpening, right side only smoothing Side by Side Comparison, left with extra edges and sharpening, right side only smoothing

$\endgroup$
  • $\begingroup$ I thought of that myself, and it's a decent method, but in the accepted answer you avoid some vertices and maybe lighting headaches. $\endgroup$ – K. Gkinis Apr 7 '18 at 21:37
  • $\begingroup$ i actually learned here something aswell :-) $\endgroup$ – eB_Bo Apr 7 '18 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.