I remember, in Dope Sheet, using Shift while dragging keyframes (I always use G) to be more precise. With 2.7, that doesn't work. I tried with 2.66... and it neither! Tried 2.57... and neither.

Am I wrong and this function never existed... or there was a version that supported it?

EDIT: I don't want to move to decimal frames (eg: 24.534). As commented, I want to move keyframes in a zoomed-out-view and be precise when dropping them.

  • $\begingroup$ Dragging value while holding Shift will provide precise control for percentile. Keyframe number is integer, so no sense to control it in this way, if I didn't misunderstand your point here. $\endgroup$ May 21, 2014 at 15:01
  • $\begingroup$ Until you get an answer, maybe you can just type in a number to be more precise: "g x 67" or "g y 3.14159" $\endgroup$
    – Mutant Bob
    May 21, 2014 at 15:11
  • $\begingroup$ If the view of the Dope Sheet is zoomed out and I want to move a keyframe just 1 frame, the mouse movement has to be so small, that I would need to press Shift to move only that frame. $\endgroup$
    – Mario Mey
    May 21, 2014 at 18:50
  • $\begingroup$ Well, you could press G 1 (as mentioned by Mutant Bob), but it would be nice if this worked (I don't use the dope sheet much, so I can't remember if it ever did). @LeonCheung In the header it displays the "deltaX" in both int and float, so I think it starts as a float, then rounds it down to an int (after reading Fweeb's answer this makes sense, the rounding is "auto snapping"). Anyway, even if it was just an int, wouldn't it work just to make the mouse have to move farther to move one frame? $\endgroup$
    – gandalf3
    May 21, 2014 at 19:38
  • $\begingroup$ Well, move only 1 frame was just an example. Imagine moving a group of vertices some thousands of frames forward... and, when you get there, you have to synch the first with other vertices in that location. $\endgroup$
    – Mario Mey
    May 21, 2014 at 20:04

1 Answer 1


When the new animation system was added, Auto Snap was enabled by default in the Dope Sheet and Graph Editor. It uses the nearest frame for snapping. You can change this behavior using a the Auto Snap dropdown menu in the header (it's in both the Dope Sheet and the Graph Editor). You can disable Auto Snap altogether by setting that dropdown to "No Auto-Snap".

  • $\begingroup$ I forgot to say that this happens in Dope Sheet. In Graph Editor, Shift does work. $\endgroup$
    – Mario Mey
    May 21, 2014 at 18:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .