2
$\begingroup$

I'm having a problem with distributing the objects I modeled in random ways. What I was able to do successfully is emit one object per face which keeps the objects from intersecting one another like this:

enter image description here

But when I vary the count of each object randomly in the particle count settings the buildings repeat in a weird pattern like this

enter image description here

As you can see if I change the count of each object in my group it should place my objects in a random pattern. Instead it seems to place them in weird strips. How do set the particle system so can adjust the amount of each object and have them placed randomly keeping one object per face

$\endgroup$
1
$\begingroup$

I noticed that you haven't changed the random slider (the one next to the 'object' slider, at the top of the particle settings). For the rest of the random settings to work, you need to make this a non-zero value. This only controls the distribution, rather than the rotation, so you shouldn't have any worries on that score.

This might not solve your one object per face issue, however. Perhaps try applying your group particle system to a plane the size of one of those faces and using an array modifier. This should achieve the intended result.

$\endgroup$
  • $\begingroup$ unfortunately the random slider next to the object slider doesn't do anything and having only one object per face is already working properly which is visible in the second picture. $\endgroup$ – Funny1048 Apr 7 '18 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.