0
$\begingroup$

Okay so basically I had to export a ton of lined up .wav strips from my blender file into audacity. So I mixdowned them with settings .wav F32 signed (1 accuracy). Then I then put in audacity. I then edited with audacity, and stuck back in blender VSE for more fine tuning/lining up with the video. Now I seem to be okay going back and forth between audacity and blender using mixdown and this .wav f32 format (1 accuracy).

But here's the part I get totally lost on though: Render settings: If I want to render audio and video together in blender my options are limited to ffmpeg h.264, a container like matroska, and then for audio codecs I have:

PCM / flac/ AAC

-Everytime I render flac with video its mute (I can mixdown with .flac but can't render it with video for some reason...idk)

-So that leaves PCM and AAC. Given my filetype you'd think PCM would be the best option. But everytime I render out with PCM I am completely underwhelmed by the result. Its like a mediocrity filter is put onto everything.

-Whereas with AAC I am generally happy with the end result.

But aac is lossy and For this project I need the highest quality audio possible as I have voice overs and music combined, thus I was using .wav f32 prior.

Also I don't trust blender when it comes to rendering audio. It always does weird stuff, especially when its changing containers. If I go aac, I'm telling it to convert a .wav f32S type into aac. Is this dangerous? Is it safer to convert in audacity and then put the aac file in blender and export as aac?

But as well this project needs to be uploaded to youtube, so aac may be better for that? I'm more inclined to believe better sounding clips regardless of container will sound better when uploaded to places like youtube, but my experience with video containers has said yielded different results...but were talking about audio so mbe its different.

Can anyone help with this convoluted mess of issues? Just any answer for any part of it would be great.

i tried looking into other programs for combining audio and video like ffmpeg or whatever, but I get completely lost...and from my knowledge it seems you can only mix ma4 or whatever files (m4a?) via that method? Then there's all this stuff about how you might need command lines to link output to each speaker....and how u might need this....or that...

$\endgroup$
  • $\begingroup$ If you render out AAC with a bitrate of 384, I doubt very much that you or anyone else will be able to differentiate between the AAC and the WAV. If you absolutely must have lossless audio, then I recommend rendering out raw from Blender and using ffmpeg to join the audio with your video. $\endgroup$ – doakey3 Apr 5 '18 at 12:35
  • $\begingroup$ Welll I rendered out in aac with 384 bitrate and rendered out in PCM with same. Then I stuck all 3 (original .wav f32s) in audacity. And PCm sounds blurry and muffled compared to the original. AAC is better but also lacks the depth of the original. I don't know how to use ffmpeg though. I can do it if I use an mp4 video and a .wav file. "Copying the audio without re-encoding If your output container can handle (almost) any codec – like MKV – then you can simply copy both audio and video streams:" ffmpeg -i video.mp4 -i audio.wav -c copy output.mkv wut is it for h.264 $\endgroup$ – kite Apr 5 '18 at 21:52
  • $\begingroup$ Like I said I seem to be able to mixdown from blender okay using the mixdown settings of .wav f32 1 accuracy. SO I can do that again.....and that gets me my audio strip. now how to combine...? like my video file is rendered.mkv ; my audio file is audio.wav; do I just set my output to any name with the extension like combined.mkv? $\endgroup$ – kite Apr 5 '18 at 21:56
  • $\begingroup$ Well I tried the command: ffmpeg -i video.mp4 -i audio.wav -c copy output.mkv and the audio was completely screwy in the output. $\endgroup$ – kite Apr 5 '18 at 23:50
  • $\begingroup$ Saying that the output was "completely screwy" isn't all that helpful. I did: ffmpeg -i video.avi -i sound.wav -vcodec libx264 -acodec copy output.mkv and it worked fine. $\endgroup$ – doakey3 Apr 6 '18 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.