1
$\begingroup$

The "rendered" viewport in the editor shows my model just fine.

enter image description hereBut once I actually render it it doesnt render the materials with it, instead everything has a gray texture. It doesnt render any lighting either.

enter image description here

I am using the cycles renderer.

Here are the nodes:

enter image description here

enter image description here

enter image description here

$\endgroup$
7
  • $\begingroup$ Those are for lighting. The render looks the same with them enabled. $\endgroup$
    – Gammel2012
    Apr 4, 2018 at 17:32
  • $\begingroup$ Is the output section in the render panel set to "rgb" or "bw" ? $\endgroup$
    – lemon
    Apr 4, 2018 at 17:34
  • $\begingroup$ Its set to rgba $\endgroup$
    – Gammel2012
    Apr 4, 2018 at 17:36
  • $\begingroup$ Please use the edit link at the bottom of your question (i.sstatic.net/lXFuK.png) and add more information on how you set up your project. Please add an image that shows the nodes you used for the material. $\endgroup$
    – user1853
    Apr 4, 2018 at 17:39
  • $\begingroup$ Did you assign the material to the faces of your object? Read: Add different materials to different parts of a mesh? $\endgroup$
    – user1853
    Apr 4, 2018 at 17:51

1 Answer 1

2
$\begingroup$

You have a material override set in your Scene>Layer panel. (Where it says 'Material'). Hit the cross in there to deactivate it.

Material Override

EDIT:

Newer versions of blender don't use layers, but "collections" so the override function is in the scene>View Layer section.

enter image description here

Additional info:

Where is the Layers panel in Blender 2.8?

2.8 - Is it possible to assign (override) a material to a whole collection?

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .