0
$\begingroup$

This question already has an answer here:

I am a beginner and have managed to create "Star Wars Crawl" in version 2.79 on Fedora 27, but cannot see any FFmpeg output option.

I have gstreamer and VLC installed and can properly play MP4 sample files in it.

As a last resort I reinstalled Blender.

What do I need to do to render my animation in MPEG format?

$\endgroup$

marked as duplicate by cegaton, David Apr 4 '18 at 14:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0
$\begingroup$

Here's my approach (right or wrong, its what I do):

*A I try to find a setting in the output dropdown that gives me the following encoding options:

*B Pick MPEG-4 (if you need to revert back to MPEG-2 That should still work, just make sure that you go the extra step in the Audio Codec section below this section and set it to mp3 - hint if I am also rendering out sound I set this anyway).

*C I personally try to use the H.264 codec, that does NOT imply that you should, its just what I do. To get a better sense of the codecs, and their respective containers, I recommend looking at to place in the manual.

Place #1

Place #2

*OUTPUT Whatever combination I pick (If I'm still unsure about it), I can see if it is going to work or not, by hard-coding the file extension of my desire, cross my fingers, and render. Sometimes I will get a default extension like *.dvd; sometimes my first extension may not work (such as *.mp4), so I try *.mpg, *.mpeg, etc...

The process seems pretty effective for me.

I will recommend this:

Try to stay away from getting lost in codec availability for your OS for now, as that is a huge topic, and you may even get lost in it. Your Blender implementation of it can probably be solved a lot quicker.

enter image description here

$\endgroup$
  • $\begingroup$ I do not have any "FFmpeg video" option, when I left click the file format box I only get 3 options for "Movie": AVI JPEG, AVI RAW and Frame Server. If I have FFmpeg installed and can play a sample MP4 file in VLC I cannot understand why is it not an option in Blender!? $\endgroup$ – Peter Hemmings Apr 4 '18 at 11:51
  • 1
    $\begingroup$ The problem was that Fedora does not default to an active ffmpeg! I downloaded the .gz version and made a Desktop link to it. I now have the relevant formats. I had not realized Fedora defaulted to limited formats! I just thought for completeness I would add this comment because it might help others! Thanks $\endgroup$ – Peter Hemmings Apr 5 '18 at 19:52
0
$\begingroup$

Try to install ffmpeg, if you didn't do this. ffmpeg contents non-free libraries, so it doesn't install by default (instead of Ubuntu).

su
rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install ffmpeg
$\endgroup$
  • $\begingroup$ [root@study peter]# dnf install ffmpeg Last metadata expiration check: 0:12:14 ago on Wed 04 Apr 2018 14:54:07 BST. Package ffmpeg-3.3.6-1.fc26.x86_64 is already installed, skipping. Dependencies resolved. Nothing to do. Complete! [root@study peter]# $\endgroup$ – Peter Hemmings Apr 4 '18 at 14:07
  • $\begingroup$ trac.ffmpeg.org/wiki/CompilationGuide/Centos $\endgroup$ – cegaton Apr 4 '18 at 14:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.