6
$\begingroup$

I am having difficulties with the Glass shader because there are no caustics and the shadows that show up in the glass shaded object look as if they are blobs of ink.
I do have the 'No Caustics' option disabled, and from the research I've done, this one checkbox is the only one that people seem to be mentioning when it comes to caustics.

Does anyone have advice on how to deal with this issue? Here's a screen capture of the scene setup that I'm working on.

enter image description here

$\endgroup$
1
  • $\begingroup$ I don't even have the "No Caustics" option. I'm also missing the "Sampling", "Light Paths" and "Volume Sampling" panes. What is going on here? $\endgroup$
    – panzi
    Jan 21, 2015 at 3:45

1 Answer 1

5
$\begingroup$

Lamps (with the exception of mesh lamps) will not cast caustics if they don't have Multiple Importance Sampling enabled on them.

Make sure any lamps in your scene have this enabled:

enter image description here

$\endgroup$
6
  • $\begingroup$ That works, I'll post the problem of exaggerated internal shadows some other time if no one shows up with ideas on that. Thanks for the caustics clarification. $\endgroup$ May 21, 2014 at 3:43
  • $\begingroup$ I found a way to clear up the inky black shadow problem. With several lights, if one of them has shadows disabled then it will brighten up the dark areas inside the mesh. $\endgroup$ May 21, 2014 at 5:48
  • $\begingroup$ Glad you got it worked out :) However, in the future, separate problems should be asked as separate questions. $\endgroup$
    – gandalf3
    May 21, 2014 at 20:13
  • $\begingroup$ I don't have such an option here. :( $\endgroup$
    – panzi
    Jan 21, 2015 at 3:48
  • $\begingroup$ @panzi What version of blender are you using? $\endgroup$
    – gandalf3
    Jan 21, 2015 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.